X.Org horizontal screen position setting - Xwindows

This is a discussion on X.Org horizontal screen position setting - Xwindows ; Hi all, I recently attached my Kubuntu machine to a new monitor, and ran dpkg-reconfigure xserver-xorg to configure X server for the new monitor.. The screen size and refresh rate is now working fine, but there is a problem with ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: X.Org horizontal screen position setting

  1. X.Org horizontal screen position setting

    Hi all,
    I recently attached my Kubuntu machine to a new monitor, and ran
    dpkg-reconfigure xserver-xorg to configure X server for the new monitor..
    The screen size and refresh rate is now working fine, but there is a problem
    with the horizontal position of the display, leading to a a black strip down
    the left of the screen, and the right side of applications being cut off.
    I can fix this by adjusting the horizontal position in the monitor menu
    (settings buttons on the monitor) but this since this monitor on a KVM this
    will cause a problem with the windows and MAC machines using the monitor.

    I'm sure this must be a setting somewhere in the X config files. I have
    looked throught /etc/X11/xorg.conf , /etc/X11/startx and other files as
    well as man pages but can't see anything. Google turns up nothing.
    Does anyone have any idea where this settiing might be?
    Thanks in advance.

    Alex.



  2. Re: X.Org horizontal screen position setting


    Alex wrote:
    > Hi all,
    > I recently attached my Kubuntu machine to a new monitor, and ran
    > dpkg-reconfigure xserver-xorg to configure X server for the new monitor..
    > The screen size and refresh rate is now working fine, but there is a problem
    > with the horizontal position of the display, leading to a a black strip down
    > the left of the screen, and the right side of applications being cut off.

    ---8<---
    > I'm sure this must be a setting somewhere in the X config files. I have
    > looked throught /etc/X11/xorg.conf , /etc/X11/startx and other files as
    > well as man pages but can't see anything. Google turns up nothing.
    > Does anyone have any idea where this settiing might be?
    > Thanks in advance.


    You need to put some ModeLine clauses into the Monitor session. I
    usually
    invoke xvidtune to generate these modelines for me as

    $ xvidtune > modes.txt

    After tunning each video mode, click at the "show" button. Quit
    xvidtune.
    The modes.txt file will contain the arguments to ModeLine clauses.
    Merge
    it to the Monitor session of xorg.conf. For example:

    Section "Monitor"
    #DisplaySize 320 240 # mm
    Identifier "Monitor0"
    VendorName "SAM"
    ModelName "SyncMaster"
    ### Comment all HorizSync and VertSync values to use DDC:
    HorizSync 30.0 - 71.0
    VertRefresh 50.0 - 160.0
    ModeLine "1400x1050" 122.00 1400 1488 1640 1880 1050
    1052 1064 1102 +hsync +vsync
    Modeline "1280x1024" 115.00 1280 1312 1496 1712 1024
    1028 1035 1078 +hsync +vsync
    ModeLine "1280x960" 108.00 1280 1332 1444 1692 960
    961 964 1000 +hsync +vsync
    ModeLine "1152x864" 108.00 1152 1196 1324 1556 864
    865 868 908 +hsync +vsync
    ModeLine "1024x768" 94.50 1024 1076 1172 1372 768
    769 772 808 +hsync +vsync
    ModeLine "800x600" 56.30 800 832 896 1048 600
    601 604 631 +hsync +vsync
    ModeLine "640x480" 36.00 640 696 752 832 480
    481 484 509 -hsync -vsync
    Option "DPMS"
    EndSection

    In the Scree section, add a line selecting the desired modes in each
    Display subsection. For example:

    Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Monitor0"
    DefaultDepth 16
    SubSection "Display"
    Viewport 0 0
    Depth 1
    Modes "1280x960" "1152x864" "1024x768" "800x600"
    "640x480"
    EndSubSection
    ..
    ..
    ..
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x960" "1152x864" "1024x768" "800x600"
    "640x480"
    EndSubSection
    EndSection


    I hope it helps.

    --- Casantos


+ Reply to Thread