Color stereo visual not found - Xwindows

This is a discussion on Color stereo visual not found - Xwindows ; We use a finite element pre/post processor called lsprepost, and have run it on a variety of unix platforms, typically displaying the results on other unix boxes or on a p.c. running exceed. We'd like to run lsprepost on an ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Color stereo visual not found

  1. Color stereo visual not found

    We use a finite element pre/post processor called lsprepost, and have run it
    on a variety of unix platforms, typically displaying the results on other
    unix boxes or on a p.c. running exceed. We'd like to run lsprepost on an
    opteron box running SuSE Linux 9.1 .
    (specifically, vivaldi.ca.boeing.com). However, if I start lsprepost on
    vivaldi and attempt to display it on my HP3000 (hp-ux 11.11) , I get the
    following errors:
    Can't obtain a full color stereo Visual
    X-ERROR: BadRequest (invalid request code or no such operation)
    Not defined
    Can't obtain a full color doublebuffered Visual
    X-ERROR: BadRequest (invalid request code or no such operation)
    Not defined
    Can't obtain a doublebuffered Visual
    X-ERROR: BadRequest (invalid request code or no such operation)
    Not defined
    Can't obtain a singlebuffered Visual(????) The program then dies.
    However, I can run the latest version of lsprepost for xeon boxes and
    display on the same HP3000 without any problem.

    Running xdpyinfo on the HP shows it has 8-plane PseudoColor, 8-plane
    TrueColor, 24-plane DirectColor, and 24-plane TrueColor visuals.
    --
    Fred L. Kleinschmidt
    Boeing Associate Technical Fellow
    Technical Architect, Software Reuse Project







  2. Re: Color stereo visual not found


    Fred Kleinschmidt wrote:
    > We use a finite element pre/post processor called lsprepost, and have run it
    > on a variety of unix platforms, typically displaying the results on other
    > unix boxes or on a p.c. running exceed. We'd like to run lsprepost on an
    > opteron box running SuSE Linux 9.1 .
    > (specifically, vivaldi.ca.boeing.com). However, if I start lsprepost on
    > vivaldi and attempt to display it on my HP3000 (hp-ux 11.11) , I get the
    > following errors:
    > Can't obtain a full color stereo Visual
    > X-ERROR: BadRequest (invalid request code or no such operation)
    > Not defined
    > Can't obtain a full color doublebuffered Visual
    > X-ERROR: BadRequest (invalid request code or no such operation)
    > Not defined
    > Can't obtain a doublebuffered Visual
    > X-ERROR: BadRequest (invalid request code or no such operation)
    > Not defined
    > Can't obtain a singlebuffered Visual(????) The program then dies.
    > However, I can run the latest version of lsprepost for xeon boxes and
    > display on the same HP3000 without any problem.


    Do you mean the xeon boxes also run SuSE 9.1 or do they run HP-UX?

    > Running xdpyinfo on the HP shows it has 8-plane PseudoColor, 8-plane
    > TrueColor, 24-plane DirectColor, and 24-plane TrueColor visuals.


    It's hard to tell. Perhaps the linux version depends on a X extension
    that is not supported by the HP-UX server, but the BadRequest error
    has the smell of a 32bit/64bit incompatibility.

    --- Casantos


+ Reply to Thread