Xwindows crashes when connecting to a Linux Box from W2k - Xwindows

This is a discussion on Xwindows crashes when connecting to a Linux Box from W2k - Xwindows ; Hello, does anyone have experience with the following setup W2k machines connecting via Exceed, XVision or Refection to Linux system and running over there a graphic intensive application. After a few hours the memory consumption of Exceed or the other ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: Xwindows crashes when connecting to a Linux Box from W2k

  1. Xwindows crashes when connecting to a Linux Box from W2k

    Hello,
    does anyone have experience with the following setup
    W2k machines connecting via Exceed, XVision or Refection to Linux
    system and running over there a graphic intensive application.
    After a few hours the memory consumption of Exceed or the other Windows
    based Xservers reaches 400-500MB and at the end they are crashing.
    This only happens when connecting to a Linux Box. Connections to HP systems
    are stable. Running KDE or Icewm changes the time until the Xserver will
    crash but it is still crashing. Using different Xserver products has only
    a minor effect.
    An other effect is that the icons turn black after a while of usage.
    The strange thing is that it only happens when connecting to a Linux box
    and not to a HP 10.20 box.
    I am running XFree86 4.3.1. KDE 3.1.

    Any input is more then welcome,

    Regards,
    Peter Eberz

  2. Re: Xwindows crashes when connecting to a Linux Box from W2k

    Peter Eberz wrote:

    > Hello,
    > does anyone have experience with the following setup
    > W2k machines connecting via Exceed, XVision or Refection to Linux
    > system and running over there a graphic intensive application.
    > After a few hours the memory consumption of Exceed or the other Windows
    > based Xservers reaches 400-500MB and at the end they are crashing.


    If the Xservers' memory consumption is growing it is because the
    clients they serve are allocating server side objects. So I would say
    that either the Linux version of the application has a bug and is
    leaking server side resources or that it's server side resource needs
    exceed what your W2K machine has to offer.

    What happens if you display the Linux version of the application
    locally or on the HP's X display?

    Have you tried more than one Winders box?

    -- ced

    > This only happens when connecting to a Linux Box. Connections to HP systems
    > are stable. Running KDE or Icewm changes the time until the Xserver will
    > crash but it is still crashing. Using different Xserver products has only
    > a minor effect.
    > An other effect is that the icons turn black after a while of usage.
    > The strange thing is that it only happens when connecting to a Linux box
    > and not to a HP 10.20 box.
    > I am running XFree86 4.3.1. KDE 3.1.
    >
    > Any input is more then welcome,
    >
    > Regards,
    > Peter Eberz



    --
    Chuck Dillon
    Senior Software Engineer
    NimbleGen Systems Inc.


  3. Re: Xwindows crashes when connecting to a Linux Box from W2k

    Peter Eberz wrote:
    > Hello,
    > does anyone have experience with the following setup
    > W2k machines connecting via Exceed, XVision or Refection to Linux
    > system and running over there a graphic intensive application.
    > After a few hours the memory consumption of Exceed or the other Windows
    > based Xservers reaches 400-500MB and at the end they are crashing.
    > This only happens when connecting to a Linux Box. Connections to HP systems
    > are stable. Running KDE or Icewm changes the time until the Xserver will
    > crash but it is still crashing. Using different Xserver products has only
    > a minor effect.
    > An other effect is that the icons turn black after a while of usage.
    > The strange thing is that it only happens when connecting to a Linux box
    > and not to a HP 10.20 box.
    > I am running XFree86 4.3.1. KDE 3.1.


    What version of Exceed? And what can you tell us about the
    graphic-intensive application?

    >
    > Any input is more then welcome,
    >
    > Regards,
    > Peter Eberz



    --
    Michel Bardiaux
    Peaktime Belgium S.A. Bd. du Souverain, 191 B-1160 Bruxelles
    Tel : +32 2 790.29.41


  4. Re: Xwindows crashes when connecting to a Linux Box from W2k


    > What version of Exceed?


    I am using currently Exceed 6.2.0.

    >And what can you tell us about the
    > graphic-intensive application?


    It is a 2D CAD/CAM software.

    Bye,
    Peter

  5. Re: Xwindows crashes when connecting to a Linux Box from W2k

    On Fri, 24 Oct 2003 09:10:04 +0000, Chuck Dillon wrote:

    > Peter Eberz wrote:
    >
    >> Hello,
    >> does anyone have experience with the following setup
    >> W2k machines connecting via Exceed, XVision or Refection to Linux
    >> system and running over there a graphic intensive application.
    >> After a few hours the memory consumption of Exceed or the other Windows
    >> based Xservers reaches 400-500MB and at the end they are crashing.

    >
    > If the Xservers' memory consumption is growing it is because the
    > clients they serve are allocating server side objects. So I would say
    > that either the Linux version of the application has a bug and is
    > leaking server side resources or that it's server side resource needs
    > exceed what your W2K machine has to offer.
    >
    > What happens if you display the Linux version of the application
    > locally or on the HP's X display?

    When I run it locally on Linux or on HPUX it runs stable. I will take a
    closer look on the possibilty of memory leakage on the Linux version of
    the application. Since our Linux boxes have much more Memory then the W2K
    machines so it might be possible that we did not realize this until now.

    I will do tests locally now on HP-UX and on Linux. Is there a way how I
    can find out if it is a problem of the X or one of the application?


    >
    > Have you tried more than one Winders box?

    Yes, I did.
    I installed the machines now from scratch, just the W2K SP4 and Exceed
    6.2.0.

    >
    > -- ced
    >
    >> This only happens when connecting to a Linux Box. Connections to HP systems
    >> are stable. Running KDE or Icewm changes the time until the Xserver will
    >> crash but it is still crashing. Using different Xserver products has only
    >> a minor effect.
    >> An other effect is that the icons turn black after a while of usage.
    >> The strange thing is that it only happens when connecting to a Linux box
    >> and not to a HP 10.20 box.
    >> I am running XFree86 4.3.1. KDE 3.1.
    >>
    >> Any input is more then welcome,
    >>
    >> Regards,
    >> Peter Eberz



  6. Re: Xwindows crashes when connecting to a Linux Box from W2k

    Peter Eberz wrote:
    >
    >
    >>What version of Exceed?

    >
    >
    > I am using currently Exceed 6.2.0.


    Aha! I had a similar problem with that one: every popup+ popdown of a
    modal dialog caused several K of *pool* memory leak on the X-server
    (Exceed) side. Now, your problem sounds like a VM leak, not a pool leak,
    so it could be different, e.g. a client-side Pixmap leak. The point is,
    that version of Exceed has *at least one* memory leak, hence it is
    entirely possible it has others.

    >
    >
    >>And what can you tell us about the
    >>graphic-intensive application?

    >
    >
    > It is a 2D CAD/CAM software.
    >
    > Bye,
    > Peter



    --
    Michel Bardiaux
    Peaktime Belgium S.A. Bd. du Souverain, 191 B-1160 Bruxelles
    Tel : +32 2 790.29.41


  7. Re: Xwindows crashes when connecting to a Linux Box from W2k

    On Mon, 27 Oct 2003 13:57:15 +0100, Michel Bardiaux wrote:

    >> I am using currently Exceed 6.2.0.

    >
    > Aha! I had a similar problem with that one: every popup+ popdown of a
    > modal dialog caused several K of *pool* memory leak on the X-server
    > (Exceed) side. Now, your problem sounds like a VM leak, not a pool leak,
    > so it could be different, e.g. a client-side Pixmap leak. The point is,
    > that version of Exceed has *at least one* memory leak, hence it is
    > entirely possible it has others.


    Do you know if there are any tools available that can help me to analyze
    this problem?

    Bye,
    Peter


  8. Re: Xwindows crashes when connecting to a Linux Box from W2k

    Peter Eberz wrote:
    > On Mon, 27 Oct 2003 13:57:15 +0100, Michel Bardiaux wrote:
    >
    >
    >>>I am using currently Exceed 6.2.0.

    >>
    >>Aha! I had a similar problem with that one: every popup+ popdown of a
    >>modal dialog caused several K of *pool* memory leak on the X-server
    >>(Exceed) side. Now, your problem sounds like a VM leak, not a pool leak,
    >>so it could be different, e.g. a client-side Pixmap leak. The point is,
    >>that version of Exceed has *at least one* memory leak, hence it is
    >>entirely possible it has others.

    >
    >
    > Do you know if there are any tools available that can help me to analyze
    > this problem?
    >
    > Bye,
    > Peter
    >

    To monitor the pool and VM usage on MSwindows: Task Manager (standard in
    W2K and WXP)

    To monitor the X protocol: xmon (http://sourceforge.net/projects/xmon/)

    HaND,
    --
    Michel Bardiaux
    Peaktime Belgium S.A. Bd. du Souverain, 191 B-1160 Bruxelles
    Tel : +32 2 790.29.41


+ Reply to Thread