I have an ACER LCD monitor with maximum resolution of 1440x900 which
I have only been able to make work at 1280x1024. The monitor does
work well at 1280x1024, but there is some horizonal stretching of
images. I have tried constructing some custom mode lines for
/etc/xorg.conf (see below), but none have worked so far.
Does anyone know how to get the monitor and video card to work at
1440x900?

Technical stuff:

K9N Neo (AMD-64) motherboard with NVidia nForce 550 series chipset
ATI Radeon Sapphire x550 PCI video card
AMD 64-bit OpenBSD 4.2 OS

xorg.conf works with both startx and startkde, just not in 1440x900 res.
The Xorg ati driver selected during configuration does not work at all
with this monitor. The Xorg vesa driver works at 1280x1024, but not at 1440x900.

=== /etc/xorg.conf ===


Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/share/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/OTF"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load "GLcore"
Load "dbe"
Load "extmod"
Load "glx"
Load "record"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "wsmouse"
Option "Device" "/dev/wsmouse"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
#DisplaySize 410 260 # mm
Identifier "Monitor0"
VendorName "ACR"
ModelName "Acer AL1916W"
### Comment all HorizSync and VertRefresh values to use DDC:
HorizSync 30.0 - 82.0
VertRefresh 56.0 - 76.0
Option "DPMS"
Modeline "1440x900" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync
Modeline "1440x900" 106.50 1440 1520 1672 1904 900 903 909 934 +hsync -vsync
EndSection

Section "Device"
### Available Driver options are:-
### Values: : integer, : float, : "True"/"False",
### : "String", : " Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # []
#Option "SWcursor" # []
#Option "Dac6Bit" # []
#Option "Dac8Bit" # []
#Option "PanelOff" # []
#Option "DDCMode" # []
#Option "MonitorLayout" # []
#Option "IgnoreEDID" # []
#Option "UseFBDev" # []
#Option "MergedFB" # []
#Option "CRT2HSync" # []
#Option "CRT2VRefresh" # []
#Option "CRT2Position" # []
#Option "MetaModes" # []
#Option "MergedDPI" # []
#Option "MergedXinerama" # []
#Option "MergedXineramaCRT2IsScreen0" # []
#Option "MergedNonRectangular" # []
#Option "MergedMouseRestriction" # []
#Option "DisplayPriority" # []
#Option "PanelSize" # []
#Option "ForceMinDotClock" #
#Option "ColorTiling" # []
#Option "VideoKey" #
#Option "RageTheatreCrystal" #
#Option "RageTheatreTunerPort" #
#Option "RageTheatreCompositePort" #
#Option "RageTheatreSVideoPort" #
#Option "TunerType" #
#Option "RageTheatreMicrocPath" #
#Option "RageTheatreMicrocType" #
#Option "RenderAccel" # []
#Option "SubPixelOrder" # []
#Option "ShowCache" # []
#Option "DynamicClocks" # []
#Option "BIOSHotkeys" # []
#Option "VGAAccess" # []
#Option "ReverseDDC" # []
#Option "LVDSProbePLL" # []
#Option "AccelMethod" #
#Option "ConstantDPI" # []
Identifier "Card0"
Driver "vesa"
VendorName "ATI Technologies Inc"
BoardName "RV370 5B60 [Radeon X300 (PCIE)]"
BusID "PCI:7:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
Modes "1440x900" "1280x1024"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1440x900" "1280x1024"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1440x900" "1280x1024"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1440x900" "1280x1024"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1440x900" "1280x1024"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1440x900" "1280x1024"
EndSubSection
EndSection

===

Any help fixing this problem will be greatly appreciated.