xawtv -hwscan on bootup - Xwindows

This is a discussion on xawtv -hwscan on bootup - Xwindows ; Hi all, I am using xawtv -hwscan to find out the available devices on my machine on bootup. It is giving proper output, when i try it using a terminal which is basically a graphical mode. But when i try ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: xawtv -hwscan on bootup

  1. xawtv -hwscan on bootup

    Hi all,

    I am using xawtv -hwscan to find out the available devices on my
    machine on bootup.
    It is giving proper output, when i try it using a terminal which is
    basically a graphical mode.
    But when i try it on boot up or on a command prompt mode, it is givng

    Error: Can't open display.

    Then i used
    xawtv -hwscan -display :0.0 from the command prompt
    this is working fine.

    But the same command when i try on bootup using rc.local, it is giving
    the following error.

    Error: Can't open display :0.0

    Then i tried using 'at' to schedule a job which will run xawtv command
    after bootup.
    This is giving the following error:

    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    Error: Can't open display: :0.0

    Somehow I need to make it work on bootup. So, is there any way to make
    it work on bootup
    Please reply as soon as possible.

    Thanks & Regards
    Thiru....


  2. Re: xawtv -hwscan on bootup

    On 2007-10-16, gs.thiru@gmail.com wrote:
    >
    > Hi all,
    >
    > I am using xawtv -hwscan to find out the available devices on my
    > machine on bootup.
    > It is giving proper output, when i try it using a terminal which is
    > basically a graphical mode.
    > But when i try it on boot up or on a command prompt mode, it is givng
    >
    > Error: Can't open display.


    Obviously, this means that the program needs an X server. If you start
    it before the X server starts, or if the DISPLAY environment variable
    isn't set, you'll get that error.

    > But the same command when i try on bootup using rc.local, it is giving
    > the following error.
    >
    > Error: Can't open display :0.0


    The X server isn't running.

    > Then i tried using 'at' to schedule a job which will run xawtv command
    > after bootup.
    > This is giving the following error:
    >
    > Xlib: connection to ":0.0" refused by server
    > Xlib: No protocol specified
    >
    > Error: Can't open display: :0.0


    Now obviously the X server IS running, but there is some sort of
    authentication issue. Try xhost + (don't if you accept TCP connections)
    and see if it helps.

    --
    John Tsiombikas (Nuclear / Mindlapse)
    http://nuclear.sdf-eu.org/

  3. Re: xawtv -hwscan on bootup

    On Oct 16, 1:33 pm, John Tsiombikas wrote:
    > On 2007-10-16, gs.th...@gmail.com wrote:
    >
    >
    >
    > > Hi all,

    >
    > > I am using xawtv -hwscan to find out the available devices on my
    > > machine on bootup.
    > > It is giving proper output, when i try it using a terminal which is
    > > basically a graphical mode.
    > > But when i try it on boot up or on a command prompt mode, it is givng

    >
    > > Error: Can't open display.

    >
    > Obviously, this means that the program needs an X server. If you start
    > it before the X server starts, or if the DISPLAY environment variable
    > isn't set, you'll get that error.
    >
    > > But the same command when i try on bootup using rc.local, it is giving
    > > the following error.

    >
    > > Error: Can't open display :0.0

    >
    > The X server isn't running.
    >
    > > Then i tried using 'at' to schedule a job which will run xawtv command
    > > after bootup.
    > > This is giving the following error:

    >
    > > Xlib: connection to ":0.0" refused by server
    > > Xlib: No protocol specified

    >
    > > Error: Can't open display: :0.0

    >
    > Now obviously the X server IS running, but there is some sort of
    > authentication issue. Try xhost + (don't if you accept TCP connections)
    > and see if it helps.
    >
    > --
    > John Tsiombikas (Nuclear / Mindlapse)http://nuclear.sdf-eu.org/


    Hi,

    I tried this 'xhost +' command from rc.local.
    i am getting the following error.
    /usr/bin/X11/xhost: unable to open display ""

    the same command works in Graphical User interface
    I want everything to work on bootup.
    what to do

    Thanks and Regards,
    Thiru...


  4. Re: xawtv -hwscan on bootup

    On 2007-10-16, gs.thiru@gmail.com wrote:
    > I tried this 'xhost +' command from rc.local.
    > i am getting the following error.
    > /usr/bin/X11/xhost: unable to open display ""
    >
    > the same command works in Graphical User interface
    > I want everything to work on bootup.
    > what to do


    Obviously, the X server must be running in order to run xhost or ANY
    OTHER X program. Isn't that clear enough ?


    --
    John Tsiombikas (Nuclear / Mindlapse)
    http://nuclear.sdf-eu.org/

+ Reply to Thread