Hello!
I got the mesa-7.0.2 package, installed it (I removed old version), but
glxinfo shows that it uses version 6.5.2;
I am using xorg 7.2, maybe should I upgrade that to 7.3?

Have fun

Ariel