Hello, I have Ubuntu Gutsy installed on a system with a 3rd-party
video card with a Radeon Mobility 9600 chipset. I have gotten normal
operations (when I'm logged in) to look fine, but for some reason GDM
doesn't display properly. Instead of the normal orange theme, I see
blue with definite signs of bad X configuration (distorted). I have
attached my X configuration file. Any words on what I could do to
remedy the problem?

Thanks in advance,
Phillip

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool,
using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades
*only*
# if it has not been modified since the last upgrade of the xserver-
xorg
# package.
#
# If you have edited this file but would like it to be automatically
updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "ATI Technologies Inc M10 NQ [Radeon Mobility 9600]"
Driver "ati"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Gateway Vivitron 17"
Option "DPMS"
HorizSync 31.5-64
VertRefresh 50-120
EndSection

Section "Screen"
Option "GARTSize" "64" #otherwise Mesa won't word properly
Identifier "Default Screen"
Device "ATI Technologies Inc M10 NQ [Radeon Mobility 9600]"
Monitor "Gateway Vivitron 17"
DefaultDepth 24
SubSection "Display"
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection