XWindows Nvidia White Screen - X

This is a discussion on XWindows Nvidia White Screen - X ; I am having problems with booting up into a really bright white screen then back to black. I select the boot option single user. Then I run startx and it goes to white screen. It is obviosly a video problem. ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: XWindows Nvidia White Screen

  1. XWindows Nvidia White Screen

    I am having problems with booting up into a really bright white screen
    then back to black. I select the boot option single user. Then I run
    startx and it goes to white screen. It is obviosly a video problem. So
    help me. I have an Nvidia Geforce Go 6150. Help me I have tried vesa
    and nv. I am now trying to install nvidia official drivers to see if
    that help. I am using debian 2.6.18 or something

  2. Re: XWindows Nvidia White Screen

    bpazolli wrote:
    > I am having problems with booting up into a really bright white screen
    > then back to black. I select the boot option single user. Then I run
    > startx and it goes to white screen. It is obviosly a video problem. So
    > help me. I have an Nvidia Geforce Go 6150. Help me I have tried vesa
    > and nv. I am now trying to install nvidia official drivers to see if
    > that help. I am using debian 2.6.18 or something


    Are you trying to run X with composite?
    If so, you might try to disable it. A common occuring 'bug' is a texture
    problem that renders the display totally white.

    Though this should not happen with VESA, since vesa does not really
    allow the composite extension to be loaded.

    Another thing you could try is recreating your X config by either
    dpkg-reconfigure or X -config.

  3. Re: XWindows Nvidia White Screen

    Jurgen Haan staggered into the Black Sun and said:
    > bpazolli wrote:
    >> I am having problems with booting up into a really bright white
    >> screen then back to black. I select the boot option single user. Then
    >> I run startx and it goes to white screen. I have an Nvidia Geforce
    >> Go 6150. I have tried vesa and nv. I am now trying to install nvidia
    >> official drivers to see if that help. I am using debian 2.6.18 or
    >> something

    > Are you trying to run X with composite? If so, you might try to
    > disable it. A common occuring 'bug' is a texture problem that renders
    > the display totally white.


    Really? There are a few X options you have to set if you want to get
    compiz-fusion working properly with nVidia cards and the evil
    binary-only nVidia modules. However, Debian doesn't make compiz-fusion
    easily available, so I doubt that's the OP's problem. The options you
    put in the Device section are like so:

    # options for compiz-fusion in Device
    Option "RenderAccel" "true"
    Option "XAANoOffscreenPixmaps"
    Option "AllowGLXWithComposite" "true"
    Option "AddARGBGLXVisuals" "true"
    Option "DisableGLXRootClipping" "true"

    # And you also need
    Section "Extensions"
    Option "Composite" "enable"
    EndSection

    > Though this should not happen with VESA, since vesa does not really
    > allow the composite extension to be loaded.


    This is something other than the composite extension. Kernel 2.6.18
    sounds like Etch. Etch is a bit less current than many distros, and
    I've heard of problems with the Geforce Go NNNN series. Is this thing
    on a laptop? If so, what's the laptop's make and model#?

    --
    ...many people in this group spent their school years taking pointless
    orders from morons and having their will to live crushed. And people
    say school doesn't prepare kids for the real world. --Rayner, in ASR
    Matt G|There is no Darkness in Eternity/But only Light too dim for us to see

+ Reply to Thread