extension "RANDR" missing on display - X

This is a discussion on extension "RANDR" missing on display - X ; when i type "xrandr -v" I am getting this error: Xlib: extension "RANDR" missing on display ":0.0". How can i include RANDR in disply? Any suggestion, Thanks, selva....

+ Reply to Thread
Results 1 to 5 of 5

Thread: extension "RANDR" missing on display

  1. extension "RANDR" missing on display

    when i type "xrandr -v"

    I am getting this error:

    Xlib: extension "RANDR" missing on display ":0.0".

    How can i include RANDR in disply?


    Any suggestion,

    Thanks,
    selva.


  2. Re: extension "RANDR" missing on display

    selva staggered into the Black Sun and said:
    > When i type "xrandr -v", I [get]:
    > Xlib: extension "RANDR" missing on display ":0.0".
    > How can I [fix this]?


    Post the output of "X -version", "lspci | grep VGA", and "grep Driver
    /etc/X11/xorg.conf". RANDR should be automatically loaded if you're
    using the appropriate X module for your video card, so I would guess
    you're using VESA or something.

    --
    Programmers are playwrights, computers are lousy actors,
    Users are vicious drama critics,
    Bastard Operators From Hell burn down theatres!
    Matt G|There is no Darkness in Eternity/But only Light too dim for us to see

  3. Re: extension "RANDR" missing on display

    On Oct 10, 7:34 pm, Dances With Crows
    wrote:
    > selva staggered into the Black Sun and said:
    >
    > > When i type "xrandr -v", I [get]:
    > > Xlib: extension "RANDR" missing on display ":0.0".
    > > How can I [fix this]?

    >
    > Post the output of "X -version", "lspci | grep VGA", and "grep Driver
    > /etc/X11/xorg.conf". RANDR should be automatically loaded if you're
    > using the appropriate X module for your video card, so I would guess
    > you're using VESA or something.
    >
    > --


    output of "X -version"

    X Window System Version 6.9.0
    Release Date: 21 December 2005
    X Protocol Version 11, Revision 0, Release 6.9
    Build Operating System: Linux 2.6.22.3 i686 [ELF]
    Current Operating System: Linux selva 2.6.22.3 #1 Mon Aug 20 17:10:32
    IST 2007 i686
    Build Date: 09 October 2007
    Before reporting problems, check http://wiki.X.Org
    to make sure that you have the latest version.
    Module Loader present

    output of "lspci | grep VGA"

    00:02.0 VGA compatible controller: Intel Corporation 82845G/
    GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
    02:0a.0 VGA compatible controller: Cirrus Logic GD 5446 (rev 45)

    output of "grep Driver /etc/X11/xorg.conf"


    Driver "kbd"
    Driver "mouse"
    Driver "cirrus"
    Driver "i810"


    Plz have a look at it. Suggest me the solution. I am facing same
    problem on Xinerama extension also.
    I am not able to use xinerama extension API's. What could be the
    soultion.



  4. Re: extension "RANDR" missing on display

    selva staggered into the Black Sun and said:
    > Dances With Crows wrote:
    >> selva staggered into the Black Sun and said:
    >> > When i type "xrandr -v", I [get]:
    >> > Xlib: extension "RANDR" missing on display ":0.0".

    >> Post the output of "X -version", "lspci | grep VGA", and "grep Driver
    >> /etc/X11/xorg.conf". RANDR should be automatically loaded if you're
    >> using the appropriate X module for your video card, so I would guess

    > X Window System Version 6.9.0
    > Release Date: 21 December 2005


    That's just a bit behind the times. I don't think it relates to your
    problem, but it might. Latest stable is 7.1 (1.3.0), dated April 2007.

    > 00:02.0 VGA compatible controller: Intel Corporation 82845G
    > 02:0a.0 VGA compatible controller: Cirrus Logic GD 5446 (rev 45)


    2 video cards. OK. Those Cirrus cards are pretty old, and they may not
    do all the things that newer cards can do. Are you using Xinerama, or
    separate Screens, or what? I don't know how xrandr interacts with
    machines that are using Xinerama or multiple screens as every machine I
    have now is single-head.

    > Driver "cirrus"
    > Driver "i810"


    These are the correct X modules.

    > Suggest me the solution.


    It's "suggest a solution". (English isn't heavy on reflexive pronouns,
    unlike some other languages.)

    > I am facing [the] same problem on [the] Xinerama extension also.


    Post your /var/log/Xorg.0.log and your /etc/X11/xorg.conf to your
    webspace (*not* to the newsgroup!) and follow up with URLs. It's
    possible that your X config is messed up in some way or you need Load
    "xinerama" in the Module section or something. I don't know for sure
    since all my machines are single-head.

    --
    "We all get our dreams stamped on from time to time, right? If it
    didn't hurt, then what kind of second-rate dreams would they be?"
    --Richard K. Morgan, _Woken Furies_
    Matt G|There is no Darkness in Eternity/But only Light too dim for us to see

  5. Re: extension "RANDR" missing on display

    On Oct 10, 6:07 am, selva wrote:
    > when i type "xrandr -v"
    >
    > I am getting this error:
    >
    > Xlib: extension "RANDR" missing on display ":0.0".
    >
    > How can i include RANDR in disply?
    >
    > Any suggestion,
    >
    > Thanks,
    > selva.


    Disable Xinerama


+ Reply to Thread