Problems with agp and nvidia driver - X

This is a discussion on Problems with agp and nvidia driver - X ; Hi, I hope this is the right group for this question. I'm having problems getting my graphics card (msi fx5700le) to work with agp in XFree86 4.3.0. I'm using the drivers from www.nvidia.com . Everything works when I disable AGP. ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Problems with agp and nvidia driver

  1. Problems with agp and nvidia driver

    Hi,

    I hope this is the right group for this question.

    I'm having problems getting my graphics card (msi fx5700le) to work
    with agp in XFree86 4.3.0.

    I'm using the drivers from www.nvidia.com. Everything works when I
    disable AGP. However, when I enable NVAGP or AGPGART in XFree86-4, my
    system freezes when i start an OpenGL application, and becomes
    generally unstable even when using only 2D.

    My motherboard (msi 865GM2-LS) is using the Intel 865G Chipset, which
    is supposed to be supported by nvidias agp.

    I've tried removing agpgart kernel modules and using only the nvidia agp,
    but that didn't seem to help.

    Does anyone have any ideas of things I can try?

    --
    Kjetil Eide

  2. Re: Problems with agp and nvidia driver

    how does default driver from xfree work. i.e., agp and all.
    you have to disable dri and agp support during the kernel compile.

    jc
    "Kjetil Eide" wrote in message
    news:m2brfszobi.fsf@online.no...
    > Hi,
    >
    > I hope this is the right group for this question.
    >
    > I'm having problems getting my graphics card (msi fx5700le) to work
    > with agp in XFree86 4.3.0.
    >
    > I'm using the drivers from www.nvidia.com. Everything works when I
    > disable AGP. However, when I enable NVAGP or AGPGART in XFree86-4, my
    > system freezes when i start an OpenGL application, and becomes
    > generally unstable even when using only 2D.
    >
    > My motherboard (msi 865GM2-LS) is using the Intel 865G Chipset, which
    > is supposed to be supported by nvidias agp.
    >
    > I've tried removing agpgart kernel modules and using only the nvidia agp,
    > but that didn't seem to help.
    >
    > Does anyone have any ideas of things I can try?
    >
    > --
    > Kjetil Eide




  3. Re: Problems with agp and nvidia driver

    "jayachandran kamaraj" writes:

    > how does default driver from xfree work. i.e., agp and all.
    > you have to disable dri and agp support during the kernel compile.
    >


    The default driver seemed to work, there seems to be mainly a problem
    with 3D hardware acceleration.

    However, I just found out I have the same problem in windows XP with
    3D programs freezing in exactly the same way, so I suspect there is a
    hardware problem.

    --
    Kjetil Eide

+ Reply to Thread