No Subject - X

This is a discussion on No Subject - X ; Subject: ATI DRI with kernel 2.6.7-r11 Lines: 16 Date: Sun, 25 Jul 2004 11:38:54 GMT NNTP-Posting-Host: 65.41.84.16 X-Complaints-To: abuse@earthlink.net X-Trace: newsread3.news.atl.earthlink.net 1090755534 65.41.84.16 (Sun, 25 Jul 2004 04:38:54 PDT) NNTP-Posting-Date: Sun, 25 Jul 2004 04:38:54 PDT Xref: number1.nntp.dca.giganews.com comp.os.linux.x:182313 Has ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: No Subject

  1. No Subject

    Subject: ATI DRI with kernel 2.6.7-r11
    Lines: 16
    Date: Sun, 25 Jul 2004 11:38:54 GMT
    NNTP-Posting-Host: 65.41.84.16
    X-Complaints-To: abuse@earthlink.net
    X-Trace: newsread3.news.atl.earthlink.net 1090755534 65.41.84.16 (Sun, 25 Jul 2004 04:38:54 PDT)
    NNTP-Posting-Date: Sun, 25 Jul 2004 04:38:54 PDT
    Xref: number1.nntp.dca.giganews.com comp.os.linux.x:182313

    Has anyone been able to get the ATI drivers to work with kernel 2.6.7?

    Accelerated 2D works fine, but 3D does not. The log shows that the agp
    driver couldn't load (x86_ENOMEM), whether using the internal AGP driver
    or the kernel AGP driver.

    Beyond that, it simply shows a block saying that DRI initialization
    failed.


    --
    - Mike

    Remove 'spambegone.net' and reverse to send e-mail.



  2. Re: ATI DRI with kernel 2.6.7-r11

    I've got a 2.6.7 kernel working and DRI enabled with my Mobility Radeon.
    I have no experience in using the ATI drivers, I'm using the radeon
    -driver provided with xorg. All I need to do is modprobe agpgart and
    modprobe ati_agp, followed by modprobe radeon. Is it the agpgart module
    which complains, or?
    -WareKala

  3. Re: ATI DRI with kernel 2.6.7-r11

    On Sun, 25 Jul 2004 11:38:54 GMT,
    Mike Ruskai , in
    wrote:
    >+ Has anyone been able to get the ATI drivers to work with kernel 2.6.7?


    No, I haven't tried recently. I have a radeon 9600 in a laptop, and it
    works adequately for me _at this time_. Maybe later when I have time
    to play.

    But there's a huge webdiscussion about this over at:

    http://www.linuxdeveloper.net/forum/...0&page=1&pp=15

    The title is "ATI driver 3.9.0 on FC2 with kernel 2.6.6". That has a
    link pointing to:

    http://rage3d.com/board/showthread.p...eadid=33763905

    which is titled "ATI 3.9.0 + FedoraC2 + Kernel 2.6.6-1.427 ok". Maybe
    not quite what you want, but I think it maybe close enough to get you
    over the hump.

    James
    --
    Consulting Minister for Consultants, DNRC
    I can please only one person per day. Today is not your day. Tomorrow
    isn't looking good, either.
    I am BOFH. Resistance is futile. Your network will be assimilated.

  4. Re: ATI DRI with kernel 2.6.7-r11

    On Sun, 25 Jul 2004 11:38:54 +0000, Mike Ruskai wrote:

    > Has anyone been able to get the ATI drivers to work with kernel 2.6.7?
    >
    > Accelerated 2D works fine, but 3D does not. The log shows that the agp
    > driver couldn't load (x86_ENOMEM), whether using the internal AGP driver
    > or the kernel AGP driver.
    >
    > Beyond that, it simply shows a block saying that DRI initialization
    > failed.


    I've that problem too. You you try this Option "BusType" "PCIE" in
    Device section on XF86Config you'll get 3d accelaration but probably will
    crash your computer. On mine it crashs after a short random period though
    i was able to play tuxracer with no problems. It crashs on X desktop no in
    tuxracer.

    Anil Mamede



+ Reply to Thread