Xfree86 ati driver and ATI Rage XL - X

This is a discussion on Xfree86 ati driver and ATI Rage XL - X ; All, I've been having some trouble getting an ATI Rage XL PCI 8mb to work with Xfree86. My first efforts were with the Xfree86 installtion that comes stock with Debian 3.0r1 (Woody). I couldn't get the card to work at ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Xfree86 ati driver and ATI Rage XL

  1. Xfree86 ati driver and ATI Rage XL

    All,

    I've been having some trouble getting an ATI Rage XL PCI 8mb to work with
    Xfree86. My first efforts were with the Xfree86 installtion that comes
    stock with Debian 3.0r1 (Woody). I couldn't get the card to work at all,
    so I downloaded and installed 4.4.0 . With that version, the system would
    hang whenever I started X - the text screen would clear, the screen would
    flash a few times, then nothing. At first I had modes up to 1280x1024 at
    depth 24 in my XF86Config-4, but I cut it down to 640x480 depth 8 (only)
    and I still couldn't get X started. I did run XFree86 -configure and
    something worked - the screen flashed a few times, and I briefly saw a
    good picture, then it flashed a few more times and hung. I was using
    the "ati" driver. scanpci correctly identified the card as a Rage XL,
    but incorrectly claimed it was an AGP card.

    I found this post
    http://groups.google.com/groups?selm....supernews.com
    that suggested the Rage XL support broke at 4.2. So I downloaded 4.1.0
    and tried that. It is more successful; I can start X and run the card
    at up to 1280x1024 at depth 24. It's still not 100%, though. I can't
    switch back to the text console once I've started X. Also, I can't get
    out of X cleanly... trying to shut down X starts to work, then the system
    hangs again. Trying to shut down the whole system from inside X also
    starts to work, but when it's time to kill X, the system hangs and doesn't
    complete the shutdown. This is still with the "ati" driver; scanpci
    claims the card is an "ATI Mach64 GM".

    Digging around in Google, it seems that others have had similar trouble
    with the ATI Rage XL chip:
    http://groups.google.com/groups?thre...0on-the-web.ch
    http://groups.google.com/groups?selm...andClement.com
    http://groups.google.com/groups?selm...mes.shef.ac.uk
    http://groups.google.com/groups?selm...0on-the-web.ch
    http://groups.google.com/groups?selm...washington.edu

    I am posting to see if anyone else with a Rage XL has had trouble, or if
    anyone has any suggestions. I plan to go next to the maintainer of the
    ati driver, Marc Aurele La France, but I wanted to check here first.

    Thanks!

    Matt Roberds


  2. Re: Xfree86 ati driver and ATI Rage XL

    In comp.os.linux.x mroberds@worldnet.att.net wrote:
    >I've been having some trouble getting an ATI Rage XL PCI 8mb to work with
    >Xfree86.


    Just to finish the story... I never was successful in getting this card
    to work well. I ended up switching to a 64 MB Radeon 7500 PCI card and
    everything is fine. Hopefully this info will help someone.

    Matt Roberds


+ Reply to Thread