Two machines on router can access internet but not each other - Wireless

This is a discussion on Two machines on router can access internet but not each other - Wireless ; Hoping someone can shed some light on this weird problem. I have a wireless router ( http://www.dynamode.net/upload/br6004wg1.pdf ). It is connected to my cable modem, and has been configured to "spoof" the network card the modem was originally configured to. ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Two machines on router can access internet but not each other

  1. Two machines on router can access internet but not each other

    Hoping someone can shed some light on this weird problem.

    I have a wireless router ( http://www.dynamode.net/upload/br6004wg1.pdf
    ). It is connected to my cable modem, and has been configured to
    "spoof" the network card the modem was originally configured to. It
    has been set to act as a DHCP server, and to assign IP addresses
    192.168.1.2 - 192.168.1.100

    Machine A is wired into it, and I have told the router to always
    assign it's MAC an IP address of 192.168.1.100 This machine can access
    the internet no problem. Both in windows and ubuntu, the network
    interface has been set to "automactically obtain IP address".

    Machine B is wireless connected. It is being assigned an IP address of
    192.168.1.99 (which I find suspicous. What happened to 192.168.1.2 ?)
    It too can happily access the internet.

    So what can't machine A ping machine B, or machine B ping machine A ?

    On both machines, after an unsuccessful ping, "ARP - A" shows the MAC
    address of the other machine.

    I tried running "Wireshark" under ubuntu to see what was happening,
    but not being a network guru didn't really understand it.

    The most annoying thing is that I've previously had 3 machines happily
    connecting to each other, both wired and wireless. So something has
    changed.

    I'm convinced something is cached in my router (which is why it
    insists on passing out .99 as the first assigned IP address). But I've
    tried restoring the factory defaults, and it's still not working.

    Can anyone suggest how to fix this please ?

  2. Re: Two machines on router can access internet but not each other


    On Mon, 28 Apr 2008 01:52:34 -0700 (PDT), Jethro
    wrote:

    >So why can't machine A ping machine B, or machine B ping machine A ?
    >


    Since both can connect to the Internet okay it's not a wireless issue.

    Presumably the subnet mask is set to 255.255.255.0?

    Ensure ICMP packets support is enabled in the router.

    Ensure ICMP packets are not blocked by firewalls.

    What do the routing tables say?



    Jim.


  3. Re: Two machines on router can access internet but not each other

    Hi
    Does your Router supports static IP within the DHCP?
    In most Routers if you want a computer to get the same IP with every log on
    you have to assign a Static IP that is out of the DHCP range.
    Jack (MVP-Networking).

    "Jethro" wrote in message
    news:20315255-f869-4ba1-9c40-d2c095fdcb2d@8g2000hse.googlegroups.com...
    > Hoping someone can shed some light on this weird problem.
    >
    > I have a wireless router ( http://www.dynamode.net/upload/br6004wg1.pdf
    > ). It is connected to my cable modem, and has been configured to
    > "spoof" the network card the modem was originally configured to. It
    > has been set to act as a DHCP server, and to assign IP addresses
    > 192.168.1.2 - 192.168.1.100
    >
    > Machine A is wired into it, and I have told the router to always
    > assign it's MAC an IP address of 192.168.1.100 This machine can access
    > the internet no problem. Both in windows and ubuntu, the network
    > interface has been set to "automactically obtain IP address".
    >
    > Machine B is wireless connected. It is being assigned an IP address of
    > 192.168.1.99 (which I find suspicous. What happened to 192.168.1.2 ?)
    > It too can happily access the internet.
    >
    > So what can't machine A ping machine B, or machine B ping machine A ?
    >
    > On both machines, after an unsuccessful ping, "ARP - A" shows the MAC
    > address of the other machine.
    >
    > I tried running "Wireshark" under ubuntu to see what was happening,
    > but not being a network guru didn't really understand it.
    >
    > The most annoying thing is that I've previously had 3 machines happily
    > connecting to each other, both wired and wireless. So something has
    > changed.
    >
    > I'm convinced something is cached in my router (which is why it
    > insists on passing out .99 as the first assigned IP address). But I've
    > tried restoring the factory defaults, and it's still not working.
    >
    > Can anyone suggest how to fix this please ?



  4. Re: Two machines on router can access internet but not each other

    Go into add and remove windows components and see if your network service and
    other network files and printer are both checked, because that was the
    problem when I couldn’t connect.

    "Jack (MVP-Networking)." wrote:

    > Hi
    > Does your Router supports static IP within the DHCP?
    > In most Routers if you want a computer to get the same IP with every log on
    > you have to assign a Static IP that is out of the DHCP range.
    > Jack (MVP-Networking).
    >
    > "Jethro" wrote in message
    > news:20315255-f869-4ba1-9c40-d2c095fdcb2d@8g2000hse.googlegroups.com...
    > > Hoping someone can shed some light on this weird problem.
    > >
    > > I have a wireless router ( http://www.dynamode.net/upload/br6004wg1.pdf
    > > ). It is connected to my cable modem, and has been configured to
    > > "spoof" the network card the modem was originally configured to. It
    > > has been set to act as a DHCP server, and to assign IP addresses
    > > 192.168.1.2 - 192.168.1.100
    > >
    > > Machine A is wired into it, and I have told the router to always
    > > assign it's MAC an IP address of 192.168.1.100 This machine can access
    > > the internet no problem. Both in windows and ubuntu, the network
    > > interface has been set to "automactically obtain IP address".
    > >
    > > Machine B is wireless connected. It is being assigned an IP address of
    > > 192.168.1.99 (which I find suspicous. What happened to 192.168.1.2 ?)
    > > It too can happily access the internet.
    > >
    > > So what can't machine A ping machine B, or machine B ping machine A ?
    > >
    > > On both machines, after an unsuccessful ping, "ARP - A" shows the MAC
    > > address of the other machine.
    > >
    > > I tried running "Wireshark" under ubuntu to see what was happening,
    > > but not being a network guru didn't really understand it.
    > >
    > > The most annoying thing is that I've previously had 3 machines happily
    > > connecting to each other, both wired and wireless. So something has
    > > changed.
    > >
    > > I'm convinced something is cached in my router (which is why it
    > > insists on passing out .99 as the first assigned IP address). But I've
    > > tried restoring the factory defaults, and it's still not working.
    > >
    > > Can anyone suggest how to fix this please ?

    >
    >


+ Reply to Thread