Problem with installation .cab file on windows CE 4.2 - Windows CE

This is a discussion on Problem with installation .cab file on windows CE 4.2 - Windows CE ; Hello I have a problem with the installation of the .cab file on Windows CE 4.2 on a touchscreen terminal. http://www.bluechips.co.th/products....&language_id=5 (=VGT001) I have made .cab file on VS 2003 ( I have made a Smart Device Application on VS2003, ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: Problem with installation .cab file on windows CE 4.2

  1. Problem with installation .cab file on windows CE 4.2

    Hello

    I have a problem with the installation of the .cab file on Windows CE
    4.2 on a touchscreen terminal.
    http://www.bluechips.co.th/products....&language_id=5
    (=VGT001)

    I have made .cab file on VS 2003 ( I have made a Smart Device
    Application on VS2003, the program works on the VS 2003 Emulator in
    debug mode), than I have made a .cab file ("Build" ==> "Build CaP
    file") => VS generates the .cab files for several processors.
    But I have instal all the .cap files, one by one, and none of theme
    work. They instal my .exe file but they don't open. ( For installing I
    have did transfer my file to the terminal (shared files) and then
    dubble click on theme for installing)


    ..net Compact Framework is installed on de Terminal (Don't know which
    version)
    Processor type: Intel (R) PXA 250
    Generated files:
    SmartDeviceApplication1_
    PPC.ARM.CAB
    PPC.ARMV4.CAB
    PPC.MIPS.CAB
    PPC.SH3.CAB
    PPC.WCE420X86.CAB
    PPC.X86.CAB
    WCE4.ARMV4.CAB
    WCE4.ARMV4T.CAB
    WCE4.MIPS16.CAB
    WCE4.MIPSII.CAB
    WCE4.MIPSII_FP.CAB
    WCE4.MIPSIV.CAB
    WCE4.MIPSIV_FP.CAB
    WCE4.SH3.CAB
    WCE4.SH4.CAB
    WCE4.X86.CAB

    What do I wrongly?


  2. Re: Problem with installation .cab file on windows CE 4.2

    On Apr 23, 2:37 am, krisvanrey...@hotmail.com wrote:
    > Hello
    >
    > I have a problem with the installation of the .cab file on Windows CE
    > 4.2 on a touchscreen terminal.
    > http://www.bluechips.co.th/products....ain_menu_id=4&...
    > (=VGT001)
    >
    > I have made .cab file on VS 2003 ( I have made a Smart Device
    > Application on VS2003, the program works on the VS 2003 Emulator in
    > debug mode), than I have made a .cab file ("Build" ==> "Build CaP
    > file") => VS generates the .cab files for several processors.
    > But I have instal all the .cap files, one by one, and none of theme
    > work. They instal my .exe file but they don't open. ( For installing I
    > have did transfer my file to the terminal (shared files) and then
    > dubble click on theme for installing)
    >
    > .net Compact Framework is installed on de Terminal (Don't know which
    > version)
    > Processor type: Intel (R) PXA 250
    > Generated files:
    > SmartDeviceApplication1_
    > PPC.ARM.CAB
    > PPC.ARMV4.CAB
    > PPC.MIPS.CAB
    > PPC.SH3.CAB
    > PPC.WCE420X86.CAB
    > PPC.X86.CAB
    > WCE4.ARMV4.CAB
    > WCE4.ARMV4T.CAB
    > WCE4.MIPS16.CAB
    > WCE4.MIPSII.CAB
    > WCE4.MIPSII_FP.CAB
    > WCE4.MIPSIV.CAB
    > WCE4.MIPSIV_FP.CAB
    > WCE4.SH3.CAB
    > WCE4.SH4.CAB
    > WCE4.X86.CAB
    >
    > What do I wrongly?


    Try ppc.x86.CAB


  3. Re: Problem with installation .cab file on windows CE 4.2

    On 23 Apr 2007 07:55:04 -0700, navin.dabhi@gmail.com wrote:

    >On Apr 23, 2:37 am, krisvanrey...@hotmail.com wrote:
    >> Hello
    >>
    >> I have a problem with the installation of the .cab file on Windows CE
    >> 4.2 on a touchscreen terminal.
    >> http://www.bluechips.co.th/products....ain_menu_id=4&...
    >> (=VGT001)
    >>
    >> I have made .cab file on VS 2003 ( I have made a Smart Device
    >> Application on VS2003, the program works on the VS 2003 Emulator in
    >> debug mode), than I have made a .cab file ("Build" ==> "Build CaP
    >> file") => VS generates the .cab files for several processors.
    >> But I have instal all the .cap files, one by one, and none of theme
    >> work. They instal my .exe file but they don't open. ( For installing I
    >> have did transfer my file to the terminal (shared files) and then
    >> dubble click on theme for installing)
    >>
    >> .net Compact Framework is installed on de Terminal (Don't know which
    >> version)
    >> Processor type: Intel (R) PXA 250
    >> Generated files:
    >> SmartDeviceApplication1_
    >> PPC.ARM.CAB
    >> PPC.ARMV4.CAB
    >> PPC.MIPS.CAB
    >> PPC.SH3.CAB
    >> PPC.WCE420X86.CAB
    >> PPC.X86.CAB
    >> WCE4.ARMV4.CAB
    >> WCE4.ARMV4T.CAB
    >> WCE4.MIPS16.CAB
    >> WCE4.MIPSII.CAB
    >> WCE4.MIPSII_FP.CAB
    >> WCE4.MIPSIV.CAB
    >> WCE4.MIPSIV_FP.CAB
    >> WCE4.SH3.CAB
    >> WCE4.SH4.CAB
    >> WCE4.X86.CAB
    >>
    >> What do I wrongly?

    >
    >Try ppc.x86.CAB


    That probably won't work because the actual device is not a PPC.

    -----------------------------------------
    To reply to me, remove the underscores (_) from my email address (and please indicate which newsgroup and message).

    Robert E. Zaret, eMVP
    PenFact, Inc.
    20 Park Plaza, Suite 400
    Boston, MA 02116
    www.penfact.com

  4. Re: Problem with installation .cab file on windows CE 4.2

    On 23 Apr 2007 00:37:34 -0700, krisvanreyten@hotmail.com wrote:

    >Hello
    >
    >I have a problem with the installation of the .cab file on Windows CE
    >4.2 on a touchscreen terminal.
    > http://www.bluechips.co.th/products....&language_id=5
    >(=VGT001)


    The link got mangled, but I did find info on the VGT-001, and assume
    that is the unit.


    >
    >I have made .cab file on VS 2003 ( I have made a Smart Device
    >Application on VS2003, the program works on the VS 2003 Emulator in
    >debug mode), than I have made a .cab file ("Build" ==> "Build CaP
    >file") => VS generates the .cab files for several processors.
    >But I have instal all the .cap files, one by one, and none of theme
    >work. They instal my .exe file but they don't open. ( For installing I
    >have did transfer my file to the terminal (shared files) and then
    >dubble click on theme for installing)


    You almost certainly saw an error message. I recommend using google
    (http://groups.google.com/advanced_group_search) to look up the first
    6 or so words of that message. Copy the text to the exact phrase
    match. If the message is in some language other than English, use the
    actual (untranslated) text.

    If that doesn't help enough, please give us more info about the
    message.

    >
    >
    >.net Compact Framework is installed on de Terminal (Don't know which
    >version)
    >Processor type: Intel (R) PXA 250


    Useful info, that I could not find online. I'm pretty sure that is ARM
    compatible. So don't waste any time with the SH3 and MIPS files.


    >
    >What do I wrongly?



    From the info you provided, we know your device uses an ARM-compatible
    CPU and version 4.2 of the Windows CE operating system. The specs I
    found for the VGT-001 say nothing about platform (see below), so I
    assume it is a proprietary platform. That is common for industrial
    devices. It means that executables built for Pocket PCs will almost
    certainly not work. So you can ignore all the PPC CAB files. That
    leaves only two CAB files that are at all likely to work:
    WCE4.ARMV4.CAB
    WCE4.ARMV4T.CAB
    My hunch is that they were built using the "standard" SDK.
    Unfortunately, that SDK is almost useless (some folks think it is
    worse than useless because it wastes time).

    For more info about "platform" and related topics, see my 19 Apr 2007
    contribution to a thread called "Handhead Terminal Casio DT-X5 and
    windows CE programming" in this newsgroup. Some of the info won't be
    relevant for you, but much of it will.

    -----------------------------------------
    To reply to me, remove the underscores (_) from my email address (and please indicate which newsgroup and message).

    Robert E. Zaret, eMVP
    PenFact, Inc.
    20 Park Plaza, Suite 400
    Boston, MA 02116
    www.penfact.com

  5. Re: Problem with installation .cab file on windows CE 4.2

    >You almost certainly saw an error message. I recommend using google
    >(http://groups.google.com/advanced_group_search) to look up the first
    >6 or so words of that message. Copy the text to the exact phrase
    >match. If the message is in some language other than English, use the
    >actual (untranslated) text.


    >If that doesn't help enough, please give us more info about the
    >message.


    I have none error message. The CAP instals my Smart Device
    Application .exe but I can't open the program. When I dubble click on
    the .exe file nothing happened.
    At the place where my Application is installed I see still two files,
    one calls vsd_config.txt and the other calls vsd_setup.dll, is that
    normal?


  6. Re: Problem with installation .cab file on windows CE 4.2

    On 23 Apr 2007 23:56:07 -0700, krisvanreyten@hotmail.com wrote:

    >>You almost certainly saw an error message. I recommend using google
    >>(http://groups.google.com/advanced_group_search) to look up the first
    >>6 or so words of that message. Copy the text to the exact phrase
    >>match. If the message is in some language other than English, use the
    >>actual (untranslated) text.

    >
    >>If that doesn't help enough, please give us more info about the
    >>message.

    >
    >I have none error message. The CAP instals my Smart Device
    >Application .exe but I can't open the program. When I dubble click on
    >the .exe file nothing happened.
    >At the place where my Application is installed I see still two files,
    >one calls vsd_config.txt and the other calls vsd_setup.dll, is that
    >normal?


    I'm really surprised you get no message when you install and no
    message when you try to run the exe once it's installed. Of course the
    message is often not useful by itself. But following my recipe for
    looking it up might have helped you find useful info.

    At any rate, the rest of my original note should help. Keep us posted.

    -----------------------------------------
    To reply to me, remove the underscores (_) from my email address (and please indicate which newsgroup and message).

    Robert E. Zaret, eMVP
    PenFact, Inc.
    20 Park Plaza, Suite 400
    Boston, MA 02116
    www.penfact.com

  7. Re: Problem with installation .cab file on windows CE 4.2

    > I'm really surprised you get no message when you install and no
    > message when you try to run the exe once it's installed. Of course the
    > message is often not useful by itself. But following my recipe for
    > looking it up might have helped you find useful info.
    >
    > At any rate, the rest of my original note should help. Keep us posted.


    I have no error, not by installation, not by running. That makes it
    more difficult for finding the problem. Could be there somthing wrong
    at VS2003? Some options for the CAB file?


  8. Re: Problem with installation .cab file on windows CE 4.2

    On 26 Apr 2007 23:11:00 -0700, krisvanreyten@hotmail.com wrote:

    >> I'm really surprised you get no message when you install and no
    >> message when you try to run the exe once it's installed. Of course the
    >> message is often not useful by itself. But following my recipe for
    >> looking it up might have helped you find useful info.
    >>
    >> At any rate, the rest of my original note should help. Keep us posted.

    >
    >I have no error, not by installation, not by running. That makes it
    >more difficult for finding the problem. Could be there somthing wrong
    >at VS2003? Some options for the CAB file?


    I think the problem is the choices you made when building the
    executable and CAB files. Please reread my original reply completely;
    I think you read only the first paragraph.

    -----------------------------------------
    To reply to me, remove the underscores (_) from my email address (and please indicate which newsgroup and message).

    Robert E. Zaret, eMVP
    PenFact, Inc.
    20 Park Plaza, Suite 400
    Boston, MA 02116
    www.penfact.com

+ Reply to Thread