IM Driver Loading Problem on PPC2003 - Windows CE

This is a discussion on IM Driver Loading Problem on PPC2003 - Windows CE ; Hi, I am trying to write MUX IM driver for PPC2003. Following PASSTHRU sample for wince, I have made changes in registry. I can see HKLM/Comm/MUX1/Parms/TCP created and filled with an IP address. My problem is I am unable to ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: IM Driver Loading Problem on PPC2003

  1. IM Driver Loading Problem on PPC2003

    Hi,
    I am trying to write MUX IM driver for PPC2003.
    Following PASSTHRU sample for wince, I have made changes in
    registry.
    I can see HKLM/Comm/MUX1/Parms/TCP created and filled with an IP
    address.
    My problem is I am unable to see packets coming out through MUX.
    Sometimes I can see UDP packets are going in/out, But TCP packets
    never.

    Can any body shade light on this?
    Any further change I should made in the registry apart from
    mentioned in PASSTHRU sample??
    Anybody has came across the same problem can share their views.

    Any suggestion or views in this regard will be a great help for me.
    Thanks in advance
    Niraj

  2. Re: IM Driver Loading Problem on PPC2003

    The problem is with the Protocol Bindings. I mean the TCP/IP is still
    binding to the actual NIC and the packets are bypassing your IM
    interface. You have to change the ProtocolsToBindTo under the actual
    NIC to bind to only to the Protocol Interface exposed by your IM. You
    may have to change the IM bindings to bind to TCP/IP.

    Try these settings and I will give you more info tomorrow.

    Good luck.

    Vani


    nirajwince@hotmail.com (Niraj) wrote in message news:<6417395.0404140723.65e00dab@posting.google.com>...
    > Hi,
    > I am trying to write MUX IM driver for PPC2003.
    > Following PASSTHRU sample for wince, I have made changes in
    > registry.
    > I can see HKLM/Comm/MUX1/Parms/TCP created and filled with an IP
    > address.
    > My problem is I am unable to see packets coming out through MUX.
    > Sometimes I can see UDP packets are going in/out, But TCP packets
    > never.
    >
    > Can any body shade light on this?
    > Any further change I should made in the registry apart from
    > mentioned in PASSTHRU sample??
    > Anybody has came across the same problem can share their views.
    >
    > Any suggestion or views in this regard will be a great help for me.
    > Thanks in advance
    > Niraj


  3. Re: IM Driver Loading Problem on PPC2003

    > interface. You have to change the ProtocolsToBindTo under the actual
    > NIC to bind to only to the Protocol Interface exposed by your IM. You


    Another way is to set the value "UpperBind" for the lower adapter to contain
    your protocol name only.

    --
    Maxim Shatskih, Windows DDK MVP
    StorageCraft Corporation
    maxim@storagecraft.com
    http://www.storagecraft.com



  4. Re: IM Driver Loading Problem on PPC2003

    Thanks All of you,

    I have tried both the things but problem remains there.

    One more thing,a Utility gives AdapterInfo gives information about
    the underlaying adapter get's hang and can't retrive the information
    back, when IM driver is loaded.
    Can any body point out the area of my mistake??

    Expecting few more suggestions from you.

    Thanks
    Niraj

+ Reply to Thread