Hi,
I have a question about hunging threads in WebSphere 6.1. We have developed a new function in our application which call a pl/sql procedure and creates an excel object from the output. The problem we have is sometimes the call gets hung in websphere and in our Oracle database also. This problems happens with apparently no reason because we've tried it at different hours and with different amount of traffic from the server and from the database. We've also tried it with the exactly same pl/sql from different machines at the same time and one after another and sometimes it gets hung and sometimes not. The pl/sql use to need 4 or 5 seconds to return but we've tried using a simple call with no sql code, just returning empty fields and it also happens.
We've changed the ojdbc driver from version 10.2.0.3 to the last one 11.2.0.2.
The Oracle version is: Oracle Database 10g Enterprise Edition Release 10.2.0.3.0
This is the trace we are getting:

Thread "WebContainer : 37" (00000057) has been active for 705633 milliseconds and may be hung. There is/are 1 thread(s) in total in the server that may be hung.

The session in our database is never killed so is consuming CPU time and slowing down the system performance so we have to kill these sessions by hand.

Has anyone have any idea why this is happening?

Thank you