Importing data from one Portal to another - Websphere

This is a discussion on Importing data from one Portal to another - Websphere ; Hi! I'm trying to export WCM data from one WS Portal 6.1 server to another server. But can't finish this task due to unknown for me errors. Please help me to understand the problem. By the way, how I can ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Importing data from one Portal to another

  1. Importing data from one Portal to another

    Hi!
    I'm trying to export WCM data from one WS Portal 6.1 server to another server.
    But can't finish this task due to unknown for me errors.
    Please help me to understand the problem.
    By the way, how I can see that the WCM data are prepared on the sourse server
    and how to see that the data are downloaded to target server?

    On the server with the data for export everything seems to be ok,
    after configuring *wkplc.properties* and *soap.client.props* the command:
    *./ConfigEngine.sh export-wcm-data -DWasUserid=wpsadmin -DWasPassword=password* executed successfully.


    But on the server for importing something was wrong:
    *./ConfigEngine.sh import-wcm-data -DWasUserid=wpsadmin -DWasPassword=password* run ok
    *./ConfigEngine.sh run-wcm-admin-task-schedule-actions -DallLibraries=true -DWasUserid=wpsadmin -DWasPassword=password* executes with error:

    ..............................
    [echo jacl.properties com.ibm.ws.scripting.port: '10025'
    [echo jacl.properties com.ibm.ws.scripting.host: 'wstest.gubkin.ru'
    action-init-cfg-files-zos:
    Wed Sep 30 11:57:47 MSD 2009
    set-properties:
    Wed Sep 30 11:57:47 MSD 2009
    [setproperty Property PortalAdminId was set to wpsadmin
    [setproperty Property PortalAdminGroupId was set to wpsadmins
    [setproperty Property WpsDocReviewer was set to cn=wpsDocReviewer,o=default organization
    [setproperty Property WpsContentAdministrators was set to cn=wpsContentAdministrators,o=default organization
    [setproperty Property UserSuffix was set to ${LDAPUserSuffix},${LDAPSuffix}
    [setproperty Property GroupSuffix was set to ${LDAPGroupSuffix},${LDAPSuffix}

    action-pre-config:
    Wed Sep 30 11:57:48 MSD 2009
    [echo executing pre-configuration tasks
    [isWas7 overwriting previous definition of property: null
    [isWas7 +++value of property is 7.0.0.0

    run-wcm-admin-task-schedule-actions:
    Wed Sep 30 11:57:48 MSD 2009

    run-wcm-admin-task:
    Wed Sep 30 11:57:53 MSD 2009
    [ConfigModuleClient Connecting to login address: http://localhost:10039/w/wcm/login
    [ConfigModuleClient Connecting to task address: http://localhost:10039/w/wcm/myconne...esources=false with username: wpsadmin
    [ConfigModuleClient This task may take some time, during which time no output will be shown. Check the SystemOut.log for progress information.

    BUILD FAILED
    /opt/IBM/WebSphere/PortalServer/wcm/prereq.wcm/config/includes/prereq.wcm_cfg.xml:2557: The following error occurred while executing this line:
    /opt/IBM/WebSphere/PortalServer/wcm/prereq.wcm/config/includes/prereq.wcm_cfg.xml:2516: An exception occurred while executing the task: null

    Total time: 1 minute 57 seconds
    isIseries currently set to: null
    uploading registry
    Created admin client: com.ibm.ws.management.AdminClientImpl@7f217f21
    Created config Service Proxy: com.ibm.websphere.management.configservice.ConfigS erviceProxy@1c6f1c6f
    CELL: myNode
    Websphere:_Websphere_Config_Data_Type=Registry,_We bsphere_Config_Data_Id=cells/myNode|registry.xml#Registry_1248686374204,_WEBSPH ERE_CONFIG_SESSION=anonymous1254297475035
    ......................................


    When I browse to http://wstest.gubkin.ru:10039/w/wcm/login, I get such error:
    *SRVE0255E: A WebGroup/Virtual Host to handle /w/wcm/login has not been defined.*
    -----

  2. Re: Importing data from one Portal to another

    Oh,
    I thought that all files will be uploaded from source server to target,
    but after export preparation they all were just copied to local directory "/opt/JCR_export"
    which is configurable in wcm60_conf.xml by "ExportDir" variable.

    So, I moved all files from SourceServer:/opt/JCR_export/rootworkspace to TargetServer:/opt/JCR_import/rootworkspace and then
    ran *./ConfigEngine.sh import-wcm-data -DWasUserid=wpsadmin -DWasPassword=password*

    After restarting server all libraries occured on their new server!

    But I can't understand why I need to setup network settings for this procedure in wcm60_conf.xml?

+ Reply to Thread