Locale settings (JVM) for currency - Websphere

This is a discussion on Locale settings (JVM) for currency - Websphere ; I thought I would quickly ask here before going too deep, currently have a Portal running under zLinux but a small problem has occurred. I'm not a Java person and have a small problem with a system where an application ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Locale settings (JVM) for currency

  1. Locale settings (JVM) for currency

    I thought I would quickly ask here before going too deep, currently have a Portal running under zLinux but a small problem has occurred. I'm not a Java person and have a small problem with a system where an application was deployed and for Germany the currency display should look something like:

    *1.234.56*

    but is showing:

    *1,234.56*

    (the *.* is being replaced with a *,*)

    The same application is running under just plain WAS and is showing the correct figures and the only difference I can see there is that I have:

    *-Dclient.encoding.override=UTF-8*

    specified in the generic JVM settings (I did this last week to umluats, etc. working.) However I am not 100% sure that this is the resolution. The developer has suggested using:

    *-Duser.language=de -Duser.country=DE*

    in the generic JVM settings but I still do not think that is the answer. Any pointers would be much appreciated.

    Seb.

  2. Re: Locale settings (JVM) for currency

    Hello,
    Sorry but try posting your question on the *IBM Java Runtimes and SDKs forum* at http://www.ibm.com/developerworks/fo...pa?forumID=367.

    Otherwise, you can create a PMR to investigate this question.

    Thank you,
    David Yang
    WebSphere Portal support

    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM.

+ Reply to Thread