Hi,

I am trying to deploy an EAR which has an Axis2 war and an ejb jar .

I had successfully deployed it in WAS 6.1.0.2 by setting one classloader for the whole EAR and keeping the application classloader as the first classloader . But the same configuration is failing in WAS 6.1.0.17.

While starting the application I get this error and the server crashes.

*java.lang.VerifyError: class loading constraint violated (class: org/apache/xerces/jaxp/SAXParserImpl method: getParser()Lorg/xml/sax/Parser at pc: 0*
* at java.lang.J9VMInternals.verifyImpl(Native Method)*
* at java.lang.J9VMInternals.verify(J9VMInternals.java: 59)*

I tried working by removing the xercesImpl jar but then it was showing up a new error

*Error: java.lang.VerifyError: org/w3c/dom/Document.getDocumentElement()Lorg/w3c/dom/Element; at com.ibm.wsdl.xml.WSDLReaderImpl.readWSDL(Unknown Source) at com.ibm.wsdl.xml.WSDLReaderImpl.readWSDL(Unknown*

Please advice at the earliest.

thanks in advance

Dev