Problem with authentication filter - Websphere

This is a discussion on Problem with authentication filter - Websphere ; I am using explicit filter to redirect URL depending upon the user logged in . Let's say user A will log in and he will land in page A. Similarly when user B will log in he will land in ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Problem with authentication filter

  1. Problem with authentication filter

    I am using explicit filter to redirect URL depending upon the user logged in .
    Let's say user A will log in and he will land in page A. Similarly when user B will log in he will land in Page B.

    I am able to do it when I use the portal login portlet but when I use my own custom portlet I am not able see the desired page .
    In case of custom portlet When I enter my credentials it shows that I am logged in but again redirects me to the same page.
    This not the case with the login portlet.This only happens when i use my custom login portlet.

    I can see in console it calls the redirect URL but the page doesn't get redirected.
    Console is same for the both case but in custom login portlet it doesn't get redirected.

    Can I get any help on this .

    Thanks

    Pranav

  2. Re: Problem with authentication filter

    Good question.. If you follow this link and go down to servlet filter I think you will have a better understanding whats missing in your custom login portlet.

    http://www.ibm.com/developerworks/we...11_abbass.html

    Additionally you can verify your code with custom portlets tab as well.

    set_cookie ( " ", " ", 2100, 01, 15, "/",
    "", "" );
    set_cookie ( " ", " ", 2100, 01,
    15, "/", "", "" );


+ Reply to Thread