I enabled SSL & Webserver compression-Browser Hanged. - Websphere

This is a discussion on I enabled SSL & Webserver compression-Browser Hanged. - Websphere ; Enabled SSL & Webserver Compression together for my web application. After logging into the application the browser getting hanged for a while and my UI is not rendering properly. I think,there might be problem in rendering the UI components at ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: I enabled SSL & Webserver compression-Browser Hanged.

  1. I enabled SSL & Webserver compression-Browser Hanged.

    Enabled SSL & Webserver Compression together for my web application.
    After logging into the application the browser getting hanged for a while and my UI is not rendering properly.
    I think,there might be problem in rendering the UI components at clent side.


    Below are the Changes made to httpd.conf file for enabling SSL and WebServer Compression:

    *#Enabling Webserver Compression*

    LoadModule deflate_module modules/mod_deflate.so

    SetOutputFilter DEFLATE
    s %b" %{outstream}n/%{instream}n (%{ratio}n%%)' deflate
    CustomLog /export/vol01/WAS_CFS/temp/deflate_log deflate

    *#Enabling SSL*

    LoadModule ibm_ssl_module modules/mod_ibm_ssl.so
    Listen 0.0.0.0:443

    ServerName 10.132.4.108
    ServerPath "/opt/IBMIHS/htdocs"
    SSLEnable
    SSLClientAuth None

    SSLEnable
    KeyFile "/opt/IBMIHS/key.kdb"


    please help me out if i am missing any thing.
    Also let me any specific configuration changes needed at Webserver Side.

  2. Re: I enabled SSL & Webserver compression-Browser Hanged.

    kinnu_2@yahoo.com wrote:
    > Enabled SSL & Webserver Compression together for my web application.
    > After logging into the application the browser getting hanged for a while and my UI is not rendering properly.
    > I think,there might be problem in rendering the UI components at clent side.
    >
    >
    > Below are the Changes made to httpd.conf file for enabling SSL and WebServer Compression:
    >
    > *#Enabling Webserver Compression*
    >
    > LoadModule deflate_module modules/mod_deflate.so
    >
    > SetOutputFilter DEFLATE
    > s %b" %{outstream}n/%{instream}n (%{ratio}n%%)' deflate
    > CustomLog /export/vol01/WAS_CFS/temp/deflate_log deflate
    >
    > *#Enabling SSL*
    >
    > LoadModule ibm_ssl_module modules/mod_ibm_ssl.so
    > Listen 0.0.0.0:443
    >
    > ServerName 10.132.4.108
    > ServerPath "/opt/IBMIHS/htdocs"
    > SSLEnable
    > SSLClientAuth None
    >
    > SSLEnable
    > KeyFile "/opt/IBMIHS/key.kdb"
    >
    >
    > please help me out if i am missing any thing.
    > Also let me any specific configuration changes needed at Webserver Side.


    You didn't show what resources you setup compression for. Try skipping
    javascript.

    --
    Eric Covener

+ Reply to Thread