I am adding a new server into exisitng WAS 5.1 cluster. The server is a clone of an existing cluster memeber. I modified the setupCmdLine.sh to use the new node name. But when I run ./addNode.sh 8889 I get a javaNullPointer error.

Review trace I see this
[11/30/09 16:47:14:264 PST] 3598991c AdminTool E ADMU0111E: Program exiting with error: java.lang.NullPointerException
at com.ibm.ws.management.tools.AbstractNodeConfigUtil ity.getResource(AbstractNodeConfigUtility.java:136 )
at com.ibm.ws.management.tools.AbstractNodeConfigUtil ity.isMemberOfCell(AbstractNodeConfigUtility.java: 129)
at com.ibm.ws.management.tools.NodeFederationUtility. runTool(NodeFederationUtility.java:270)
at com.ibm.ws.management.tools.AdminTool.executeUtili ty(AdminTool.java:188)
at com.ibm.ws.management.tools.NodeFederationUtility. main(NodeFederationUtility.java:164)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:85)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:58)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:60)
at java.lang.reflect.Method.invoke(Method.java:391)
at com.ibm.ws.bootstrap.WSLauncher.run(WSLauncher.jav a:222)
at java.lang.Thread.run(Thread.java:570)

[11/30/09 16:47:14:271 PST] 3598991c SOAPConnector d invoke
public abstract java.lang.Object com.ibm.ws.management.RemoteAdminService.invoke(ja vax.management.ObjectName,java.lang.String,java.la ng.Object[],java.lang
String[]) throws javax.management.InstanceNotFoundException,javax.m anagement.MBeanException,javax.management.Reflecti onException,com.ibm.websphere.management.exception .ConnectorException
[Ljava.lang.Object;@1515991f

I am testing without security. is there something I am missing? Or is there something I need to modify on the /WebSphere51/AppServer directory to make this server ready to be added as a new node?