IHS V7 Can not start - Websphere

This is a discussion on IHS V7 Can not start - Websphere ; I have installed IHS V7 on AIX 5.3. When start it, I am getting following error, [/opt/IBMIHS/HTTPServer/bin]./apachectl start httpd: Syntax error on line 793 of /opt/IBMIHS/HTTPServer/conf/httpd.conf: Cannot load /opt/IBMIHS/HTTPServer/Plugins/bin/mod_was_ap20_http.so into server: rtld: 0712-001 Symbol ap_run_http_method was referenced from module /opt/IBMIHS/HTTPServer/Plugins/bin/mod_was_ap20_http.so(), ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: IHS V7 Can not start

  1. IHS V7 Can not start

    I have installed IHS V7 on AIX 5.3. When start it, I am getting following error,

    [/opt/IBMIHS/HTTPServer/bin]./apachectl start
    httpd: Syntax error on line 793 of /opt/IBMIHS/HTTPServer/conf/httpd.conf: Cannot load /opt/IBMIHS/HTTPServer/Plugins/bin/mod_was_ap20_http.so into server: rtld: 0712-001 Symbol ap_run_http_method was referenced from module /opt/IBMIHS/HTTPServer/Plugins/bin/mod_was_ap20_http.so(), but a runtime definition of the symbol was not found.rtld: 0712-001 Symbol apr_sockaddr_port_get was referenced from module /opt/IBMIHS/HTTPServer/Plugins/bin/mod_was_ap20_http.so(), but a runtime definition of the symbol was not found.

    Anyone has ideas?

  2. Re: IHS V7 Can not start

    On Sep 17, 5:06*pm, ericdu wrote:
    > I have installed IHS V7 on AIX 5.3. When start it, I am getting followingerror,
    >
    > [/opt/IBMIHS/HTTPServer/bin]./apachectl start
    > httpd: Syntax error on line 793 of /opt/IBMIHS/HTTPServer/conf/httpd.conf: Cannot load /opt/IBMIHS/HTTPServer/Plugins/bin/mod_was_ap20_http.so into server: rtld: 0712-001 Symbol ap_run_http_method was referenced from module/opt/IBMIHS/HTTPServer/Plugins/bin/mod_was_ap20_http.so(), but a runtime definition * * of the symbol was not found.rtld: 0712-001 Symbol apr_sockaddr_port_get was referenced from module /opt/IBMIHS/HTTPServer/Plugins/bin/mod_was_ap20_http.so(), but a runtime definition of the symbol was not found.
    >
    > Anyone has ideas?

    Might be something in the AIX environment variables, LIBPATH perhaps?
    Check that there are archive files containing the methods you want
    contained in libraries on the LIBPATH when you start the HTTP server.
    I seem to remember that the nm and ar commands are useful in finding
    shared objects and library contents on AIX.

    Pete Bennett
    www.dsps.net
    www.middleware-dsps.blogspot.com

  3. Re: IHS V7 Can not start

    did you check that the path is correct. Is the mod_was_ap20_http.so file found at /opt/ibmIHS/HTTPServer/Plugins/bin?

    Also since you are using IHS v7, are you also using v7 of WAS and the Plugin? Or are you using v6 or v6.1 etc?

    If you are using WAS and Plugin v7..then you should be using mod_was_ap22_http.so instead of ap20.

  4. Re: IHS V7 Can not start

    Thanks for the response. It works now. We have IHSV7 working with WAS5 and WAS7. it needs to change mod_was_ap20_http.so to mod_was_ap22_http.so. Plus leaving,
    LoadModule authz_host_module modules/mod_authz_host.so
    LoadModule auth_basic_module modules/mod_auth_basic.so
    LoadModule authn_file_module modules/mod_authn_file.so
    LoadModule authz_user_module modules/mod_authz_user.so

    from WAS7

+ Reply to Thread