MQ 5.3 on EL 4/5 (2.6 kernel) - Websphere

This is a discussion on MQ 5.3 on EL 4/5 (2.6 kernel) - Websphere ; Hi, I know MQ 5.3 is very old, but is it all possible to install it on Red Hat Enterprise Linux 4 or 5, with Linux 2.6 kernels? At the moment when we try to create MQ queues, we get ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: MQ 5.3 on EL 4/5 (2.6 kernel)

  1. MQ 5.3 on EL 4/5 (2.6 kernel)

    Hi,

    I know MQ 5.3 is very old, but is it all possible to install it on Red Hat Enterprise Linux 4 or 5, with Linux 2.6 kernels?

    At the moment when we try to create MQ queues, we get the following error message:

    AMQ6220: Unsupported thread library detected.

    We are using MQ version 5.3.0.1 with the 5.3.0.14 upgrade RPMs (Fix Pack 14) for Linux/Intel.

    I have read up on the IBM support pages regarding MQ version 5.3 using the LinuxThreads model of the Linux 2.4 kernel instead of the NPTL threading model provided with Linux 2.6 kernel. But I seem to remember it mentioned somewhere that it works on some 2.6 kernels.

    I have tried setting the following environment variables before installing the packages and before creating the queue, but it doesn't seem to help:

    export LD_ASSUME_KERNEL=2.4.19
    export AMQ_THREADMODEL_RESET=1
    export RPM_FORCE_NPTL=1

    It continues then to return:

    /opt/mqm/bin/crtmqm: error while loading shared libraries: libm.so.6: cannot open shared object file: No such file or directory

    Some of this is based on how it is supposedly able to run on EL 3.0 (http://www-01.ibm.com/support/docvie...id=swg27007475), though that is I believe a 2.4 kernel.

    So in short: Is it possible to run MQ 5.3 on a Linux 2.6 kernel (Enterprise Linux 5.3 in particular, but any EL5.x oer EL4.x would do) and how would one do that?


    Regards,

    AM

  2. Re: MQ 5.3 on EL 4/5 (2.6 kernel)

    ...and yes, I know that MQ 5.3 was End Of Support late 2007, so I know I have to upgrade to MQ6/MQ7 soon :-).

+ Reply to Thread