MQ resource adapter issue on JBoss/Linux - Websphere

This is a discussion on MQ resource adapter issue on JBoss/Linux - Websphere ; I am seeing similar error as in Thread: [ http://www.ibm.com/developerworks/fo...78&tstart=150] The Error is: {code}2009-07-09 09:50:50,258 INFO [org.jboss.resource.deployers.RARDeployment] (main) Required license terms exist, view vfszip …/wmq.jmsra.rar/META-INF/ra.xml 2009-07-09 09:50:50,307 ERROR [org.jboss.kernel.plugins.dependency.AbstractKernel Controller] (main) Error installing to Start: name=jboss.jca:name='wmq.jmsra.rar',service=RARDep loyment state=Create mode=Manual requiredState=Installed ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: MQ resource adapter issue on JBoss/Linux

  1. MQ resource adapter issue on JBoss/Linux

    I am seeing similar error as in Thread:
    [http://www.ibm.com/developerworks/fo...78&tstart=150]

    The Error is:
    {code}2009-07-09 09:50:50,258 INFO [org.jboss.resource.deployers.RARDeployment] (main) Required license terms exist, view vfszip …/wmq.jmsra.rar/META-INF/ra.xml
    2009-07-09 09:50:50,307 ERROR [org.jboss.kernel.plugins.dependency.AbstractKernel Controller] (main) Error installing to Start: name=jboss.jca:name='wmq.jmsra.rar',service=RARDep loyment state=Create mode=Manual requiredState=Installed
    java.lang.NoSuchMethodError: com.ibm.mq.MQEnvironment.setXaLicenseMsg(I)V
    at com.ibm.mq.OSE. (OSE.java:155)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:247)
    at com.ibm.mq.MQEnvironment$1.run(MQEnvironment.java: 532)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.ibm.mq.MQEnvironment. (MQEnvironment.java:525)
    at com.ibm.mq.connector.ResourceAdapterImpl.(Resource AdapterImpl.java:139){code}

    My environment is: linux fedora 6, jboss-5.1.0.GA, MQ 6.0.2.5.
    I have installed com.ibm.mqetclient.jar file in the server profile libs, as determined here:

    [http://www.ibm.com/developerworks/we..._ritchie.html]

    I have upgrated MQ to 6.0.2.5 and replaced wmq.jmsra.rar to new one, as determined here:

    [http://www-01.ibm.com/support/docvie...t171websphere]

    but error still occur. The same server works on Windows platform.

    wmq.jmsra.rar is new one after installing fix pack 6.0.2.5 but com.ibm.mqetclient.jar is old one from installation cd of MQ, because there isn’t new one in installation directory of MQ. Should I use new com.ibm.mqetclient.jar, if yes, where I can download this library?

    Might be other workaround ?

    Regards
    Mgn

  2. Re: MQ resource adapter issue on JBoss/Linux

    You can download the latest MQ Client from the following location:
    http://www-01.ibm.com/support/docvie...AGX10&S_CMP=LP

  3. Re: MQ resource adapter issue on JBoss/Linux

    But *com.ibm.mqetclient.jar* - WebSphere MQ Extended Transactional Client jar are unavailable in the Java for MQ client download.
    Where can I find new version of this jar?

    Regards
    Mgn

  4. Re: MQ resource adapter issue on JBoss/Linux

    I have resolved my issue. First, I didn't install Java Extended Transaction Support on MQ 6.0.1.0.
    That's why fix pack 6.0.2.5 didn't update *com.ibm.mqetclient.jar* because it was missing in my installation directory.
    I found new version of *com.ibm.mqetclient.jar* inside the unzipped fix pack.

+ Reply to Thread