IHS throwing error 500 for 1 ip only - Websphere

This is a discussion on IHS throwing error 500 for 1 ip only - Websphere ; Hi, we have 2 IHS servers, communicating with the same WAS instance. Each IHS Servers has 2 ips (due to the load balance needs). So when I call: IHS Server1 with the first ip: http://192.168.1.1/application it works when I call ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: IHS throwing error 500 for 1 ip only

  1. IHS throwing error 500 for 1 ip only

    Hi, we have 2 IHS servers, communicating with the same WAS instance.

    Each IHS Servers has 2 ips (due to the load balance needs).
    So when I call: IHS Server1 with the first ip: http://192.168.1.1/application it works
    when I call IHS Server1 with the second ip: http://192.168.1.2/application it works

    When I call IHS Server2 with the first ip: http://192.168.1.3/application it works
    But when I call the IHS Server2 with the other ip, ex: http://192.168.1.4/application it is throwing error 500.

    I have no idea what is going on. I also tried a telnet call from the same machine
    When I tried:
    telnet 192.168.1.4 80
    GET /application/index.html HTTP/1.1
    Host: 192.168.1.3
    It worked also

    but when I change the Host: to 192.168.1.4 it received the error 500


    I really dont know where else to look at. I can affirm that the IP interfaces are ok and working, it looks like that when I call with the ip above, the IHS is getting lost when "connect" to the plugin-config.xml file, I cannot think another way to receive an 500 error.


    doest anybody have any clue?

    Thanks!

    Ricardo

  2. Re: IHS throwing error 500 for 1 ip only

    What host aliases have been defined in the virtual host used by application?

    -Sunit

    wrote in message
    news:518384275.1244821824540.JavaMail.wassrvr@ltsg was009.sby.ibm.com...
    > Hi, we have 2 IHS servers, communicating with the same WAS instance.
    >
    > Each IHS Servers has 2 ips (due to the load balance needs).
    > So when I call: IHS Server1 with the first ip:
    > http://192.168.1.1/application it works
    > when I call IHS Server1 with the second ip: http://192.168.1.2/application
    > it works
    >
    > When I call IHS Server2 with the first ip: http://192.168.1.3/application
    > it works
    > But when I call the IHS Server2 with the other ip, ex:
    > http://192.168.1.4/application it is throwing error 500.
    >
    > I have no idea what is going on. I also tried a telnet call from the same
    > machine
    > When I tried:
    > telnet 192.168.1.4 80
    > GET /application/index.html HTTP/1.1
    > Host: 192.168.1.3
    > It worked also
    >
    > but when I change the Host: to 192.168.1.4 it received the error 500
    >
    >
    > I really dont know where else to look at. I can affirm that the IP
    > interfaces are ok and working, it looks like that when I call with the ip
    > above, the IHS is getting lost when "connect" to the plugin-config.xml
    > file, I cannot think another way to receive an 500 error.
    >
    >
    > doest anybody have any clue?
    >
    > Thanks!
    >
    > Ricardo



  3. Re: IHS throwing error 500 for 1 ip only

    If you try turning the log level in the plugin-cfg.xml file up to
    trace (but don't do this for long!) and restart the HTTP server, take
    a look at the plugin-trace information that gets written to the plugin
    log file, that might well give you a clue.

    netstat -an | findstr 9080
    or
    netstat -an | grep 9080
    (Or which ever port your WAS application is listening upon) from the
    IHS machine, might well show what connections are established, or
    possibly which ones aren't.

    The access log file for the HTTP server might also report upon errors.

    Pete Bennett
    Distributed Systems Professional Services



    On Jun 12, 4:49*pm, ricardo...@gmail.com wrote:
    > Hi, we have 2 IHS servers, communicating with the same WAS instance.
    >
    > Each IHS Servers has 2 ips *(due to the load balance needs). *
    > So when I call: IHS Server1 *with the first ip:http://192.168.1.1/application* *it works
    > when I call IHS Server1 with the second ip:http://192.168.1.2/application* it works
    >
    > When I call IHS Server2 with the first ip:http://192.168.1.3/applicationit works
    > But when I call the IHS Server2 with the other ip, ex:http://192.168.1.4/application*it is throwing error 500.
    >
    > I have no idea what is going on. *I also tried a telnet call from the same machine
    > When I tried:
    > telnet 192.168.1.4 80
    > GET /application/index.html HTTP/1.1
    > Host: 192.168.1.3
    > It worked also
    >
    > but when I change the Host: to 192.168.1.4 *it received the error 500
    >
    > I really dont know where else to look at. *I can affirm that the IP interfaces are ok and working, it looks like that when I call with the ip above, *the IHS is getting lost when "connect" *to the plugin-config.xml file, I cannot think another way to receive an 500 error.
    >
    > doest anybody have any clue?
    >
    > Thanks!
    >
    > Ricardo



  4. Re: IHS throwing error 500 for 1 ip only

    In general error 500 also called internal server error is related to application service error. deploy the same app on another ip and check it how it performs?

+ Reply to Thread