HTTP Server hidden into wasservice.exe... - Websphere

This is a discussion on HTTP Server hidden into wasservice.exe... - Websphere ; Hello, A provider installed us WAS 6.1 base package on a standalone windows 2003 configuration. He tells me that he installed IBM HTTP server but i can't see - any IBM HTTP server in the Windows services list - any ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: HTTP Server hidden into wasservice.exe...

  1. HTTP Server hidden into wasservice.exe...

    Hello,

    A provider installed us WAS 6.1 base package on a standalone windows 2003 configuration. He tells me that he installed IBM HTTP server but i can't see
    - any IBM HTTP server in the Windows services list
    - any httpd.conf file on the server
    - any webserver in the webserver list into the administation console

    The only processes i have are WASservice.exe and the java.exe JVM

    When i get back to my provider with those informations he tells me that the http server is "hidden" into wasservice.exe

    Question : is that possible ? if yes, how can i control/manage that http server apart (ie. stop/start/status etc?.) ?

    Thanks a lot

  2. Re: HTTP Server hidden into wasservice.exe...

    lmorel@lgfrance.com wrote:
    > Hello,
    >
    > A provider installed us WAS 6.1 base package on a standalone windows 2003 configuration. He tells me that he installed IBM HTTP server but i can't see
    > - any IBM HTTP server in the Windows services list
    > - any httpd.conf file on the server
    > - any webserver in the webserver list into the administation console
    >
    > The only processes i have are WASservice.exe and the java.exe JVM
    >
    > When i get back to my provider with those informations he tells me that the http server is "hidden" into wasservice.exe
    >
    > Question : is that possible ? if yes, how can i control/manage that http server apart (ie. stop/start/status etc?.) ?
    >
    > Thanks a lot


    If there's no httpd.conf, IHS is not installed.

    Ken

  3. Re: HTTP Server hidden into wasservice.exe...

    Hi, The IHS server does not have to be installed to use a Windows' Service. Do you have an install directory? You can go to "IHS_HOME/bin/apachectl -k start" to start the web server.

    Regards,
    Brian

  4. Re: HTTP Server hidden into wasservice.exe...

    In fact, i've got no IHS directory : it looks like there is no http server but the application is working : urls http://*.do mapped to a servlet...can this work without any http server installed ???

  5. Re: HTTP Server hidden into wasservice.exe...

    lmorel@lgfrance.com wrote:
    > In fact, i've got no IHS directory : it looks like there is no http server but the application is working : urls http://*.do mapped to a servlet...can this work without any http server installed ???


    Yes, this can work. Your installer must have setup the web container to
    listen on port 80.

    Ken

+ Reply to Thread