SqlServer 2005 driver version is not clear on WAS 6.1.0.17 - Websphere

This is a discussion on SqlServer 2005 driver version is not clear on WAS 6.1.0.17 - Websphere ; I downloaded sql server driver 1.2 from the MS site. I added the sqljdbc.jar to a new provider that I created on WAS 6.1.0.17. When the server comes up I get the following details: [10/22/08 11:12:23:064 EDT] 0000001d InternalGener I ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: SqlServer 2005 driver version is not clear on WAS 6.1.0.17

  1. SqlServer 2005 driver version is not clear on WAS 6.1.0.17

    I downloaded sql server driver 1.2 from the MS site.
    I added the sqljdbc.jar to a new provider that I created on WAS 6.1.0.17. When the server comes up I get the following details:
    [10/22/08 11:12:23:064 EDT] 0000001d InternalGener I DSRA8203I: Database product name : Microsoft SQL Server
    [10/22/08 11:12:23:096 EDT] 0000001d InternalGener I DSRA8204I: Database product version : 9.00.1399
    [10/22/08 11:12:23:096 EDT] 0000001d InternalGener I DSRA8205I: JDBC driver name : Microsoft SQL Server 2005 JDBC Driver
    [10/22/08 11:12:23:096 EDT] 0000001d InternalGener I DSRA8206I: *JDBC driver version : 1.1.1501.101*

    Then when I run/use the dataSource I get the following:

    [10/22/08 11:13:52:716 EDT] 0000002b DSConfigurati I DSRA8203I: Database product name : Microsoft SQL Server
    [10/22/08 11:13:52:716 EDT] 0000002b DSConfigurati I DSRA8204I: Database product version : 9.00.1399
    [10/22/08 11:13:52:731 EDT] 0000002b DSConfigurati I DSRA8205I: JDBC driver name : Microsoft SQL Server 2005 JDBC Driver
    [10/22/08 11:13:52:731 EDT] 0000002b DSConfigurati I DSRA8206I: *JDBC driver version : 1.2.2828.100*
    [10/22/08 11:13:52:747 EDT] 0000002b DSConfigurati I DSRA8025I: Successfully connected to DataSource.

    My question is why does it say 1.1... at startup and then 1.2. What is it really using? This is misleading and confusing. I need to make sure that the correct version is actually being picked up. My application is getting a weird error where the SQL generated from EJB3 annotations is invalid. I believe it is a persistence.xml config issue and not a jdbc driver, but I am not ruling it out due to the inconsistant messages and the errors I am getting. BTW this application works on JBoss. See the caused by application error below:

    Caused by: org.apache.openjpa.persistence.PersistenceExceptio n: Invalid column name 'id'. {prepstmnt 1735681908 SELECT t0.id, t0.Version, t0.CreateDate, t0.CreatedBy, t0.Deleted, t0.DomainId, t0.UpdateDate, t0.UpdatedBy, t0.Name FROM Statuses t0 WHERE (t0.Deleted = ?) [params=(int) 0]} [code=207, state=S0001]
    at org.apache.openjpa.jdbc.sql.DBDictionary.newStoreE xception(DBDictionary.java:3951)
    at org.apache.openjpa.jdbc.sql.SQLExceptions.getStore (SQLExceptions.java:97)
    at org.apache.openjpa.jdbc.sql.SQLExceptions.getStore (SQLExceptions.java:83)
    at org.apache.openjpa.jdbc.sql.SQLExceptions.getStore (SQLExceptions.java:59)
    at org.apache.openjpa.jdbc.kernel.SelectResultObjectP rovider.handleCheckedException(SelectResultObjectP rovider.java:155)
    at org.apache.openjpa.lib.rop.EagerResultList.(EagerR esultList.java:40)
    at org.apache.openjpa.kernel.QueryImpl.toResult(Query Impl.java:1223)
    at org.apache.openjpa.kernel.QueryImpl.execute(QueryI mpl.java:990)
    at org.apache.openjpa.kernel.QueryImpl.execute(QueryI mpl.java:799)
    at org.apache.openjpa.kernel.QueryImpl.execute(QueryI mpl.java:769)
    at org.apache.openjpa.kernel.QueryImpl.execute(QueryI mpl.java:765)
    at org.apache.openjpa.kernel.DelegatingQuery.execute( DelegatingQuery.java:517)
    at org.apache.openjpa.persistence.QueryImpl.execute(Q ueryImpl.java:238)
    at org.apache.openjpa.persistence.QueryImpl.getResult List(QueryImpl.java:277) at org.apache.openjpa.jdbc.sql.SQLExceptions.getStore (SQLExceptions.java:97)

    Any direction on this would be great. Any direction on what might be missing from the persistence.xml would be appreciated as well. I am on a very tight deadline. Thank you in advance.

  2. Re: SqlServer 2005 driver version is not clear on WAS 6.1.0.17

    Moving to the correct forum. My mistake.
    New location: http://www-128.ibm.com/developerwork...hreadID=230843

+ Reply to Thread