unable to choose realm from manage virtual portal portlet - Websphere

This is a discussion on unable to choose realm from manage virtual portal portlet - Websphere ; Hi, I am a rookie to websphere portal. I´m using v6.01 portal, and i cannot choose a realm when I create a new virtual portal from the manage virtual portal portlet!! Any ideas ? /Jonas...

+ Reply to Thread
Results 1 to 14 of 14

Thread: unable to choose realm from manage virtual portal portlet

  1. unable to choose realm from manage virtual portal portlet

    Hi,

    I am a rookie to websphere portal. I´m using v6.01 portal, and i cannot choose a realm when I create a new virtual portal from the manage virtual portal portlet!!

    Any ideas ?

    /Jonas

  2. Re: unable to choose realm from manage virtual portal portlet

    Have you defined any realms in wmmur.xml?

    -FF

    The postings on this site are my own and do not necessarily represent the positions, strategies or opinions of IBM.

  3. Re: unable to choose realm from manage virtual portal portlet

    Yes, I have defined 2 realms, but I do not get the dropdownbox in the portlet to give a new virtual portal a realm !!

  4. Re: unable to choose realm from manage virtual portal portlet

    Did you restart the server after creating the realms? The new realms will not be shown until the server is restarted.

    -FF

    The postings on this site are my own and do not necessarily represent the positions, strategies or opinions of IBM.

  5. Re: unable to choose realm from manage virtual portal portlet

    Hi

    What kind of Security have you choosen?

    For Multiple Realms you have to use WMM UR as security environment for WebSphere and restart is important.

  6. Re: unable to choose realm from manage virtual portal portlet

    Hi,

    Yes I have restarted the server after I added the new realm. Where do I choose wmmur as security ?

  7. Re: unable to choose realm from manage virtual portal portlet

    See the Planning page here, and then click your way into the relevant security pages:
    http://publib.boulder.ibm.com/infoce...n_sec_cfg.html

    Basically, you have to run enable-security-wmmur-ldap instead of enable-security-ldap when configuring portal security.

    -Brett Gordon (WebSphere Portal L2 Support)

    IBM Certified System Administrator -- WebSphere Portal V6.0, V5.1, V5.0
    IBM Certified Solution Developer -- WebSphere Portal V5.1, v6.0

    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM.

  8. Re: unable to choose realm from manage virtual portal portlet

    Hi,

    I did not install the portal myself (unfortunately)......What will happen if I run the enable-security-vmmur-ldap command, if it has allready been executed ? - Is there a way to check if command has been executed ?

  9. Re: unable to choose realm from manage virtual portal portlet

    Hi,

    I did not install the portal myself (unfortunately)......What will happen if I run the enable-security-vmmur-ldap command, if it has allready been executed ? - Is there a way to check if command has been executed ?

    /Jonas

  10. Re: unable to choose realm from manage virtual portal portlet

    You can check your ConfigTrace.log in /log to look at your config task history.

    You can also post your security.xml as an attachment and I'll tell you whether you have realm support enabled (or you can check yourself what you have for the activeUserRegistry value).

    To switch to realm support, you'd have to disable security via the disable-security task and then run the enable-securitiy-wmmur-ldap task. However, please note that this procedure drops the tables in the WMM database, (not clear if this was just a test box or something in production), so if you are storing values in there such as lookaside or application group data, these would be gone.

    -Brett Gordon (WebSphere Portal L2 Support)

    IBM Certified System Administrator -- WebSphere Portal V6.0, V5.1, V5.0
    IBM Certified Solution Developer -- WebSphere Portal V5.1, v6.0

    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM.

  11. Re: unable to choose realm from manage virtual portal portlet

    In security.xml, search for "activeUserRegistry". If it has value to "LDAP...", then
    it's not WMMUR. If it's "Custom...", then you already have WMMUR.

    -FF

    The postings on this site are my own and do not necessarily represent the positions, strategies or opinions of IBM.

  12. Re: unable to choose realm from manage virtual portal portlet

    My security.xml says : activeUserRegistry="CustomUserRegistry_1"

    I spoke with the IBM consultant that installed the server, and he said that he had installed it with enable-security-vmmur !!. The box is a testbox, but it was installed simultaniously with two other servers, that work just fine !! - I don´t know where to look !! I tried to login to one of the virtual portals and created an user. It was not created in the realm, but in the default repository of LDAP.

  13. Re: unable to choose realm from manage virtual portal portlet

    I found something that looks a bit strange. I compared security.xml from the box that did not work with one of the boxes that works fine. The first line in the security.xml from the not
    working box says :



    And from the working box :



    I don´t know if it has something to say !!

  14. Re: unable to choose realm from manage virtual portal portlet

    Hi,

    I fixed the problem. I found out that global security was not enabled in my WAS. I enabled it, and then it worked.

    Thanks for all your replys

    /Jonas

+ Reply to Thread