websphere application improving lnitial load times - Websphere

This is a discussion on websphere application improving lnitial load times - Websphere ; Hi, My environment has websphere 6.1 base edition, IBM Httpserver 6.1, running on windows server 2003 enterprise edition. The server got 10 gb memory, 8 way cpu and I am running two profiles on websphere. We are running wiki application ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: websphere application improving lnitial load times

  1. websphere application improving lnitial load times

    Hi,

    My environment has websphere 6.1 base edition, IBM Httpserver 6.1, running on windows server 2003 enterprise edition. The server got 10 gb memory, 8 way cpu and I am running two profiles on websphere. We are running wiki application (browser based,deployed as an EAR in websphere 6.1) and it is running fine. My Issue is, whenever I am accessing the application through my browser for the first time it takes more than 15 seconds to load on my browser and during subsequently access it is loading very fast (3-4 secs) must be from the browser cache. When the application loads up on the browser, it takes us to the login screen where user credentials are checked against the LDAP server and takes me to the main page. This entire steps takes 15 secs (during iniital access). I have enabled dynamic caching and enabled servlet caching on my admin console. But no improvement in the loading time. Please can you suggest some fine tuning steps inorder to improve load times of the application.

    Thanks in advance

    Regards
    Siva

  2. Re: websphere application improving lnitial load times

    sivagct@yahoo.com wrote:
    > Hi,
    >
    > My environment has websphere 6.1 base edition, IBM Httpserver 6.1, running on windows server 2003 enterprise edition. The server got 10 gb memory, 8 way cpu and I am running two profiles on websphere. We are running wiki application (browser based,deployed as an EAR in websphere 6.1) and it is running fine. My Issue is, whenever I am accessing the application through my browser for the first time it takes more than 15 seconds to load on my browser and during subsequently access it is loading very fast (3-4 secs) must be from the browser cache. When the application loads up onthe browser, it takes us to the login screen where user credentials are checked against the LDAP server and takes me to the main page. This entire steps takes 15 secs (during iniital access). I have enabled dynamic caching and enabled servlet caching on my admin console. But no improvement in the loading time. Please can you suggest some fine tuning steps inorder to improve load times of the application.
    >
    > Thanks in advance
    >
    > Regards
    > Siva
    >

    Siva,
    Probably the best thing to do is instrument your code to know what's
    taking the time.

    Sounds like your LDAP lookup could be the culprit, but you're just
    guessing without hard data.

    Ken

  3. Re: websphere application improving lnitial load times

    This may be a silly question, but are your JSPs pre-compiled, and the
    relevant servlets init() ed during server start-up?

  4. Re: websphere application improving lnitial load times

    First, You can change the application settings to load at startup. So at the time of server startup it will keep everything ready. Though startup time will be longer, initial response will be fast.

  5. Re: websphere application improving lnitial load times

    Hi,

    Thanks for you suggestion and there is little improvement in the load times after adjusting the startup behaviour and enabling launch application before server completes startup. Once I have entered my LDAP credentials, (it gets authenticated with my remote ldap server) it takes almost 20 secs to get authenticated and complete the round about. Do you have any suggestions to improve this login times from websphere prespective ?

    Thank you
    Siva

  6. Re: websphere application improving lnitial load times

    sivagct@yahoo.com wrote:
    > Hi,
    >
    > Thanks for you suggestion and there is little improvement in the load
    > times after adjusting the startup behaviour and enabling launch
    > application before server completes startup. Once I have entered my
    > LDAP credentials, (it gets authenticated with my remote ldap server)
    > it takes almost 20 secs to get authenticated and complete the round
    > about. Do you have any suggestions to improve this login times from
    > websphere prespective ?


    Find out why your LDAP is taking so long to respond. This doesn't sound
    like a WAS problem. Perhaps there are some network issues, or the LDAP
    server itself is very slow.

  7. Re: websphere application improving lnitial load times

    This sounds like an LDAP problem, not a WebSphere problem. Do you mean you configured your servlets to init on startup? Have you tried pre-compiling your JSPs?

+ Reply to Thread