SSL connection failure: GSK_ERROR_SOCKET_CLOSED(gsk rc = 420) - Websphere

This is a discussion on SSL connection failure: GSK_ERROR_SOCKET_CLOSED(gsk rc = 420) - Websphere ; I am trying to set up SSL on my Windows XP machine, which I am running WAS 6.1 and HTTPServer 6.1 I have a self signed certificate on my machine, for SSL testing purposes, but do not believe the self ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: SSL connection failure: GSK_ERROR_SOCKET_CLOSED(gsk rc = 420)

  1. SSL connection failure: GSK_ERROR_SOCKET_CLOSED(gsk rc = 420)

    I am trying to set up SSL on my Windows XP machine, which I am running WAS 6.1 and HTTPServer 6.1
    I have a self signed certificate on my machine, for SSL testing purposes, but do not believe the self signed certificate is the problem, becuase I am getting it displated (and I am accepting it).

    When I enter http://localhost in my browser, I get the HTTP Server Admin home page, as expected.
    When I enter https://localhost in my browser, I get the HTTP Server Admin home page, as expected.
    When I enter http://localhost/MyWebProgram in my browser, I get the MyWebProgram Login, as expected.
    When I enter https://localhost/MyWebProgram in my browser, I get presented the certificate, then I get this error page:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, you@your.address and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    ________________________________________
    IBM_HTTP_Server Server at localhost Port 443

    The Http_plugin.log contains the following error messages:
    [Fri Aug 29 07:31:07 2008] 0000092c 00000e3c - ERROR: lib_stream: openStream: Failed in r_gsk_secure_soc_init: GSK_ERROR_SOCKET_CLOSED(gsk rc = 420)
    [Fri Aug 29 07:31:07 2008] 0000092c 00000e3c - ERROR: ws_common: websphereGetStream: Could not open stream
    [Fri Aug 29 07:31:07 2008] 0000092c 00000e3c - ERROR: ws_common: websphereExecute: Failed to create the stream
    [Fri Aug 29 07:31:07 2008] 0000092c 00000e3c - ERROR: ws_common: websphereHandleRequest: Failed to execute the transaction to 'CLTKEY2Node01_MWP'on host 'CLTKEY2.corp.mycompany.com'; will try another one
    [Fri Aug 29 07:31:07 2008] 0000092c 00000e3c - ERROR: ws_common: websphereWriteRequestReadResponse: Failed to find an app server to handle this request
    [Fri Aug 29 07:31:07 2008] 0000092c 00000e3c - ERROR: ws_common: websphereRequestHandler: Failed to find an app server to handle this request
    [Fri Aug 29 07:31:07 2008] 0000092c 00000e3c - ERROR: ws_common: websphereHandleRequest: Failed to handle request

    When I researched the GSK_ERROR_SOCKET_CLOSED(gsk rc = 420) Error, all I can find is that one end of socket conversation closed. (not much help).

    I am pretty sure I have WAS and the plugin_cfg.xml configured correctly, as I get all the ports opened and listening correctly, (snipit from the systemout.log)

    [8/29/08 7:45:39:717 EDT] 0000000a TCPChannel I TCPC0001I: TCP Channel TCP_1 is listening on host * (IPv4) port 9061.
    [8/29/08 7:45:39:733 EDT] 0000000a WSChannelFram A CHFW0019I: The Transport Channel Service has started chain WCInboundAdmin.
    [8/29/08 7:45:39:733 EDT] 0000000a TCPChannel I TCPC0001I: TCP Channel TCP_2 is listening on host * (IPv4) port 9081.
    [8/29/08 7:45:39:748 EDT] 0000000a WSChannelFram A CHFW0019I: The Transport Channel Service has started chain WCInboundDefault.
    [8/29/08 7:45:39:764 EDT] 0000000a TCPChannel I TCPC0001I: TCP Channel TCP_3 is listening on host * (IPv4) port 9044.
    [8/29/08 7:45:39:764 EDT] 0000000a WSChannelFram A CHFW0019I: The Transport Channel Service has started chain WCInboundAdminSecure.
    [8/29/08 7:45:39:764 EDT] 0000000a TCPChannel I TCPC0001I: TCP Channel TCP_4 is listening on host * (IPv4) port 9449.


    I know I have done something wrong, but can't see the forest thru the trees, as even putting the port directly in the url https://localhost:9449/MyWebProgram/ does not bring up the MyWebProgram login screen, and it should. Instead I get:

    The page cannot be displayed
    The page you are looking for is currently unavailable.
    The Web site might be experiencing technical difficulties,
    or you may need to adjust your browser settings.



    Can anyone help?

  2. Re: SSL connection failure: GSK_ERROR_SOCKET_CLOSED(gsk rc = 420)

    kyoder@carreker.com wrote:

    > The Http_plugin.log contains the following error messages:
    > [Fri Aug 29 07:31:07 2008] 0000092c 00000e3c - ERROR: lib_stream: openStream: Failed in r_gsk_secure_soc_init: GSK_ERROR_SOCKET_CLOSED(gsk rc = 420)
    > [Fri Aug 29 07:31:07 2008] 0000092c 00000e3c - ERROR: ws_common: websphereGetStream: Could not open stream
    > [Fri Aug 29 07:31:07 2008] 0000092c 00000e3c - ERROR: ws_common: websphereExecute: Failed to create the stream


    You sure the host/port the plugin is trying to connect to is actually
    speaking SSL? You can just point a browser there.

    This does not appear to be the FAQ of the plugin just not trusting the
    AppServer's certificate.


    --
    Eric Covener

  3. Re: SSL connection failure: GSK_ERROR_SOCKET_CLOSED(gsk rc = 420)

    Hi.

    Any logging in the SystemOut.log for the application server ?

    Do you have any virtual_host in WAS that listening to port 443 ? Is
    the application mapped to that virtual_host ?

    /MiJo

  4. Re: SSL connection failure: GSK_ERROR_SOCKET_CLOSED(gsk rc = 420)

    hi,

    Can someone tell me what was the solution because I have the same problem.

    thk.

+ Reply to Thread