Problem while deploying an MDB in WAS6.1 1.0.15 Fix pack - Websphere

This is a discussion on Problem while deploying an MDB in WAS6.1 1.0.15 Fix pack - Websphere ; We migrated from WAS5.0 to WAS 6.1 .Sysadmin upgarded the webpshere 6.1 version with fixpack 6.1.0.15 and when i am deploying the MDB ,I am getting below error . *WASX7017E: Exception received while running file "/apps/nnos/pco/pcopcwc_v11.3.1/bin/installenpcwcApp.jacl"; exception information: org.eclipse.jst.j2ee.commonarchivecore.internal.ex ception.DeploymentDescriptorL ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Problem while deploying an MDB in WAS6.1 1.0.15 Fix pack

  1. Problem while deploying an MDB in WAS6.1 1.0.15 Fix pack

    We migrated from WAS5.0 to WAS 6.1 .Sysadmin upgarded the webpshere 6.1 version with fixpack 6.1.0.15 and when i am deploying the MDB ,I am getting below error .



    *WASX7017E: Exception received while running file "/apps/nnos/pco/pcopcwc_v11.3.1/bin/installenpcwcApp.jacl"; exception information: org.eclipse.jst.j2ee.commonarchivecore.internal.ex ception.DeploymentDescriptorL oadException: org.eclipse.jst.j2ee.commonarchivecore.internal.ex ception.DeploymentDescriptorL oadException: IWAE0022E Exception occurred loading deployment descriptor META-INF/application.xml for module "enpcWorkstepCompleteMDB.jar" in EAR file "/tmp/app12197.ear"*Let me know if any one got this problem ,This MDB was properly working on WAS5.0 .



    Thanks in advance for your help .

  2. Re: Problem while deploying an MDB in WAS6.1 1.0.15 Fix pack

    Hi, There are plenty of changes between WebSphere 5.0 and WebSphere 6.1. The standards have changed considerably and I would suggest trying to update your ear file, at least the deployed XML files, to the newer standards.



    WebSphere AS v.5.0 is no longer supported by IBM.



    Regards,

    Brian

  3. Re: Problem while deploying an MDB in WAS6.1 1.0.15 Fix pack

    Thanks for your response .I opened a PMR with IBM and the problem was in my MDB



    META-INF/ejb-jar.xml file it shows as below .

    javax.jms.queue.Topic


    which needs to be either queue or Topic .It was not a problem in WAS5.1 .



    After correcting the ejb-jar.xml with javax.jms.Topic


    Its depolyed properly .

+ Reply to Thread