apachectl -k restart - Websphere

This is a discussion on apachectl -k restart - Websphere ; Is it safe to run "apachectl -k restart" as nonroot? I noticed that you can run some other flags as nonroot user (i.e. -t, -v), but those are pretty trivial. I'm pretty sure that the -k start|stop commands need to ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: apachectl -k restart

  1. apachectl -k restart

    Is it safe to run "apachectl -k restart" as nonroot? I noticed that you can run some other flags as nonroot user (i.e. -t, -v), but those are pretty trivial. I'm pretty sure that the -k start|stop commands need to be root, but what about restart|graceful? Current version is IHS 6.1 on AIX.

  2. Re: apachectl -k restart

    riceburner480@yahoo.com wrote:
    > Is it safe to run "apachectl -k restart" as nonroot? I noticed that you can run some other flags as nonroot user (i.e. -t, -v), but those are pretty trivial. I'm pretty sure that the -k start|stop commands need to be root, but what about restart|graceful? Current version is IHS 6.1 on AIX.


    If the same non-root user didn't originally start the server:

    a) it won't restart
    b) it will probably give you some misleading error in the terminal

    (if you fool it into getting farther, -k restart still needs to send
    kill -SIGTERM to the parent process, which a non-root user cannot do)


    If the same non-root user did originally start the sever: No problem.

    --
    Eric Covener

  3. Re: apachectl -k restart

    On Unix systems you cannot use non-root user to start apache if the ports
    being listened on are below 1024 (e.g. 80 for http and 443 for https).

    - Sunit


    wrote in message
    news:2118835498.1211576180746.JavaMail.wassrvr@lts gwas010.sby.ibm.com...
    > Is it safe to run "apachectl -k restart" as nonroot? I noticed that you
    > can run some other flags as nonroot user (i.e. -t, -v), but those are
    > pretty trivial. I'm pretty sure that the -k start|stop commands need to
    > be root, but what about restart|graceful? Current version is IHS 6.1 on
    > AIX.



+ Reply to Thread