Migrate from WebSphere 5.1 to 6.1 Error - SECJ0055E: Authenticationfailed - Websphere

This is a discussion on Migrate from WebSphere 5.1 to 6.1 Error - SECJ0055E: Authenticationfailed - Websphere ; Hi All, After migrating our application from WAS 5.1 to 6.1, when login the application using username/password previously worked in WAS 5.1, the server log had error: MethodDelegat A SECJ0055E: Authentication failed for . The user id or password may ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Migrate from WebSphere 5.1 to 6.1 Error - SECJ0055E: Authenticationfailed

  1. Migrate from WebSphere 5.1 to 6.1 Error - SECJ0055E: Authenticationfailed

    Hi All,



    After migrating our application from WAS 5.1 to 6.1, when login the application using username/password previously worked in WAS 5.1, the server log had error:



    MethodDelegat A SECJ0055E: Authentication failed for . The user id or password may have been entered incorrectly or misspelled. The user id may not exist, the account could have expired or disabled. The password may have expired.



    The login seemed working fine, but the server kept posting the error. Any special security setup needed after migration to WAS 6.1? We used UserRegistry in WAS 5.1



    Thanks for any help!

  2. Re: Migrate from WebSphere 5.1 to 6.1 Error - SECJ0055E: Authenticationfailed

    yx_guo@yahoo.com wrote:
    > Hi All,
    >
    >
    >
    > After migrating our application from WAS 5.1 to 6.1, when login the
    > application using username/password previously worked in WAS 5.1, the
    > server log had error:
    >
    >
    >
    > MethodDelegat A SECJ0055E: Authentication failed for . The user id or
    > password may have been entered incorrectly or misspelled. The user id
    > may not exist, the account could have expired or disabled. The
    > password may have expired.
    >
    >
    >
    > The login seemed working fine, but the server kept posting the error.
    > Any special security setup needed after migration to WAS 6.1? We used
    > UserRegistry in WAS 5.1


    What do you mean, you used UserRegistry? There are three registry
    options in WAS 5.1 - LDAP, Local OS or Custom. Which one did you use?
    Are you using the same registry in 6.1? (Which also adds a new option,
    Federated User Registry a.k.a. VMM).

  3. Re: Migrate from WebSphere 5.1 to 6.1 Error - SECJ0055E:Authentication failed

    We implemented a plugin registry to extend com.ibm.websphere.security.UserRegistry.



    In WebSphere 6.1, I didn't change anything for upgrading. I just ran the upgrade wizard in 6.1, and didn't change any security configuration. I'm not very familiar with the security setup here. After login to our application, the user/password error keeps coming up in the server log.



    Thanks for any pointer to where I should look at.

  4. Re: Migrate from WebSphere 5.1 to 6.1 Error - SECJ0055E: Authenticationfailed

    yx_guo@yahoo.com wrote:
    > We implemented a plugin registry to extend
    > com.ibm.websphere.security.UserRegistry.
    >
    >
    >
    > In WebSphere 6.1, I didn't change anything for upgrading. I just ran
    > the upgrade wizard in 6.1, and didn't change any security
    > configuration. I'm not very familiar with the security setup here.
    > After login to our application, the user/password error keeps coming
    > up in the server log.
    >
    >
    >
    > Thanks for any pointer to where I should look at.


    Make sure that your new WAS 6.1 cell is using the same custom registry
    and it's configured correctly. Talk to someone in your company who is
    familiar with it.

  5. Re: Migrate from WebSphere 5.1 to 6.1 Error - SECJ0055E:Authentication failed

    Do you know what names the sas.jar, idl.jar, runtime.jar, admin.jar in WAS 5 changed to in WAS 6.1?



    Thanks.

+ Reply to Thread