Remote User Details in WSRP - Websphere

This is a discussion on Remote User Details in WSRP - Websphere ; We are doing a proof of concept for WAS 6.1 WAS 6.1 has a light weight producer component and we have used it to for creating my producer. we created a local portlet which has code of request.getRemoteUser() in it. ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Remote User Details in WSRP

  1. Remote User Details in WSRP

    We are doing a proof of concept for WAS 6.1



    WAS 6.1 has a light weight producer component and we have used it to for creating my producer. we created a local portlet which has code of request.getRemoteUser() in it.



    we are consuming the portlet on WPS 6.0 and we need the portlet to display the remote user. However when we checked the logs it displays as null.



    ON doing some research, we found out that since the user is unauthenticated it is not able to get remoteUser.



    since we are doing a local poc we havent used LTPA or SSL. However we have used com.ibm.wps.wsrp.securityprovider.defaultimpl_1.0. 0.jar for authorization provider.



    We configured it and on producer side when we checked it gave a pop up for username and password and when we entered those values, we were able to see the details for remote user



    When we tried to access the portlet on consumer side, it still gave as null. We then found that a credential slot needs to be created that can be used to pass the username and password. We did that but then it shows up as access denied to the portlet.



    Has anybody done this before or can somebody provide details step on how to configure the producer and consumer so that we can get the remote user details.



    Any help would be greatly appreciated.

  2. Re: Remote User Details in WSRP

    Bumping up this old thread - maybe someone has answers. We are trying to achieve the same but not have been successful. In addition, is there any way to pass TAM headers (like iv-groups) from the consumer to the producer?

    Using WSRP 2.0 with WAS7.1 and WPS6.1

+ Reply to Thread