I am trying to create a datasource at cell level. I think I need to
use the provider id from the resource.xml?

wsadmin>set newjdbc [$AdminConfig getid /Cell:wswsdev1Network/Node:/
JDBCProvide
r:JDBCProvider_1194014960712/DataSourceS1/ ]
wssdweb1.abcompany.com(cells/wswsdev1Network/nodes/
wssdweb1.abcompany.com|node.xml
#Node_1165418198165)
wssdweb2.abcompany.com(cells/wswsdev1Network/nodes/
wssdweb2.abcompany.com|node.xml
#Node_1165418219995)
wswsdev1Manager(cells/wswsdev1Network/nodes/wswsdev1Manager|
node.xml#Node_1)
wswsdev5Node01(cells/wswsdev1Network/nodes/wswsdev5Node01|
node.xml#Node_1)

====
One of our servers "wswsdev2" isn't listed here. It is in the
wswsdev1Network cell as far as I know.
====


wsadmin>set name[list name DS1]
name DS1
wsadmin>set dsAttrs[list $name]
{name DS1}
wsadmin>set newds [$AdminConfig create DataSource $newjdbc $dsAttrs]
WASX7015E: Exception running command: "set newds [$AdminConfig create
DataSource
$newjdbc $dsAttrs]"; exception information:
com.ibm.ws.scripting.ScriptingException: WASX7025E: Error found in
String "{_We
bsphere_Config_Data_Display_Name=wssdweb1.abcompan y.com(cells/
wswsdev1Network/nod
es/wssdweb1.abcompany.com|node.xml#Node_1165418198165 )
wssdweb2.abcompany.com(cells/wswsdev1Network/nodes/
wssdweb2.abcompany.com|node.xml
#Node_1165418219995)
wswsdev1Manager(cells/wswsdev1Network/nodes/wswsdev1Manager|
node.xml#Node_1)
wswsdev5Node01, _Websphere_Config_Data_Id=cells/wswsdev1Network/nodes/
wswsdev5No
de01|node.xml#Node_1}"; cannot create ObjectName.