Re: Problems with update installer: WAS 6.0.2.3 to WAS 6.0.2.5 onWindows - Websphere

This is a discussion on Re: Problems with update installer: WAS 6.0.2.3 to WAS 6.0.2.5 onWindows - Websphere ; I was installing fixpack on WAS 6.0.2.9 to upgrade to 6.0.2.17, the installation got aborted because of some network issue @ our end. However the server version info was showing as 6.0.2.17,so i went in for fixpack uninstallation. The uninstall ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Re: Problems with update installer: WAS 6.0.2.3 to WAS 6.0.2.5 onWindows

  1. Re: Problems with update installer: WAS 6.0.2.3 to WAS 6.0.2.5 onWindows

    I was installing fixpack on WAS 6.0.2.9 to upgrade to 6.0.2.17, the installation got aborted because of some network issue @ our end. However the server version info was showing as 6.0.2.17,so i went in for fixpack uninstallation. The uninstall was successfull, but when I tried reinstallation I was facing the same error you had been getting. I replaced the "version" folder under <appserver-root>/properties with one of my another WAS servers "version" folder(6.0.2.17). Now the server version info was showing as 6.0.2.17(though it was just 6.0.2.9). I again went in for fixpack unistallation and reinstallation. Then all worked fine for me.

    moral of the story : The error is got to do with the "version" folder which maintains the backup of old configuration. When installation terminates unexpectedly; probably the version info gets scrambled..

  2. Re: Problems with update installer: WAS 6.0.2.3 to WAS 6.0.2.5 onWindows

    Hi,
    I was installing the WAS fix pak 6.0.2.9.25 on my WAS 6.0.2.9 ,I am getting the following error.
    UpdateInstaller, com.ibm.ws.install.ni.ismp.actions.PopulateUninsta llableIfixList, err, java.lang.NullPointerException
    at com.ibm.ws.install.ni.ismp.utils.ISMPLogUtils.logE xception(ISMPLogUtils.java:42)
    at com.ibm.ws.install.ni.ismp.actions.PopulateUninsta llableIfixList.execute(PopulateUninstallableIfixLi st.java:67)
    at com.installshield.wizard.StandardWizardListener.ex ecute(StandardWizardListener.java:123)
    at com.installshield.wizard.StandardWizardListener.cu rrentBeanChanged(StandardWizardListener.java:106)
    at com.installshield.wizard.Wizard$RunThread.run(Wiza rd.java:1569)

    You said that bythe replace of the version directory in /proprties directory with some other version directory. What is that new version directory,how you get that,I have only one version directory in my system for this.How to get that.Please explain me in some more detail,so that I will try and fix the problem.Could someone give the solution to my problem?

  3. Re: Problems with update installer: WAS 6.0.2.3 to WAS 6.0.2.5 onWindows

    On Mar 11, 4:37*pm, seetha_da...@yahoo.com wrote:
    > Hi,
    > * * * *I was installing the WAS fix pak 6.0.2.9.25 on my WAS 6.0.2.9 ,I am getting the following error.
    > *UpdateInstaller, com.ibm.ws.install.ni.ismp.actions.PopulateUninsta llableIfixList, err, java.lang.NullPointerException
    > * * * * at com.ibm.ws.install.ni.ismp.utils.ISMPLogUtils.logE xception(ISMPLogUtils.jav*a:42)
    > * * * * at com.ibm.ws.install.ni.ismp.actions.PopulateUninsta llableIfixList.execute(Po*pulateUninstallableIfixL ist.java:67)
    > * * * * at com.installshield.wizard.StandardWizardListener.ex ecute(StandardWizardListe*ner.java:123)
    > * * * * at com.installshield.wizard.StandardWizardListener.cu rrentBeanChanged(Standard*WizardListener.java:106)
    > * * * * at com.installshield.wizard.Wizard$RunThread.run(Wiza rd.java:1569)
    >
    > You said that bythe replace of the version directory in /proprties directory with some other version directory. What is that new version directory,how you get that,I have only one version directory in my system for this.Howto get that.Please explain me in some more detail,so that I will try and fix the problem.Could someone give the solution to my problem?


    I may be able to find the reason if you can send me the file /
    properties/version/update/backup/maintenanceStack.xml and all the
    fileNAMEs of the /properties/version/update/backup directory
    (only filenames).

    I am sure IBM support would be able to resolve this for you quickly.


+ Reply to Thread