Re: Failed to initialize virtual portal - Websphere

This is a discussion on Re: Failed to initialize virtual portal - Websphere ; I'm also getting this error. Any progress with a fix? I am using WAS 6.0.1.19 and Portal 6.0.1.1 on Windows 2003....

+ Reply to Thread
Results 1 to 4 of 4

Thread: Re: Failed to initialize virtual portal

  1. Re: Failed to initialize virtual portal

    I'm also getting this error. Any progress with a fix? I am using WAS 6.0.1.19 and Portal 6.0.1.1 on Windows 2003.

  2. Re: Failed to initialize virtual portal

    Any progress on the error?
    i too use WPS6.1 and getting the same issue. In addition to the log posted in am getting the below log also.

    Find below the error that i get.

    +EJPXA0025E: The resource was not found in the portal, either because it does not exist or because you have not specified an identifying attribute in the XML input.+
    +com.ibm.wps.command.xml.XmlCommandException: EJPXA0025E: The resource was not found in the portal, either because it does not exist or because you have not specified an identifying attribute in the XML input. [web-app] at com.ibm.wps.command.xml.UpdateEngine.locateItem(Up dateEngine.java:385) at com.ibm.wps.command.xml.UpdateEngine.processItem(U pdateEngine.java:201) at com.ibm.wps.command.xml.UpdateEngine.updateTopLeve lItem(UpdateEngine.java:168) at com.ibm.wps.command.xml.XmlAccessHandler.fillObjec tModel(XmlAccessHandler.java:343) at com.ibm.wps.command.xml.XmlAccessHandler.endElemen t(XmlAccessHandler.java:225) at org.apache.xerces.parsers.AbstractSAXParser.endEle ment(Unknown Source) at org.apache.xerces.impl.xs.XMLSchemaValidator.endEl ement(Unknown Source) at org.apache.xerces.impl.XMLNSDocumentScannerImpl.sc anEndElement(Unknown Source) at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl$FragmentContentDispatcher.dispatch(Unknown Source)+

  3. Re: Failed to initialize virtual portal

    The initialization XML scripts delivered with portal were created based on a standard configuration with out-of-the-box portlets and pages. If you removed some portlets or pages and then try to create virtual portals, you may encounter this problem. What you need to do is to get a full export from your base portal and then check whether the resources are missing, deleted, or changed. You may have to delete or comment them out from the standard initialization XML file. Or you can create a customized VP init XML script based on the export from your base portal.

    -FF

    The postings on this site are my own and do not necessarily represent the positions, strategies or opinions of IBM.

  4. Re: Failed to initialize virtual portal

    In the error log that i got i was not able to identify which webapp was missing. To resolve this initialization failure, i took all the web apps that is there in InitVitualPortal.xml in a seperate xml file and ran it through the xmlaccess from Portal Server bin. By running so, we can get exactly where the script is failing.
    Search for the failed application war in myportal administration console. If not present take the war from installableApps of PortalServer and install the same and then try initializing the vp.

    This will solve the root of this problem.

+ Reply to Thread