WDSC update development software: Who? - Websphere

This is a discussion on WDSC update development software: Who? - Websphere ; Hi, Since a couple of years now we are using WDSC or it's former versions. From time to time we had to upgrade this developer software because of the upgrade of our Websphere Application Server. Last year we decided not ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: WDSC update development software: Who?

  1. WDSC update development software: Who?

    Hi,

    Since a couple of years now we are using WDSC or it's former versions. From
    time to time we had to upgrade this developer software because of the
    upgrade of our Websphere Application Server. Last year we decided not to
    upgrade and kept on using Websphere version 4.0.7 Untill we got that fine
    message from IBM that WSAS 4.x was not supported anymore...

    We had to opgrade the WebServer to V5.x and because of that we also needed
    to upgrade our WDSC because our version did not support WSAS V5. And yes, I
    know, Version 6 is already on the market... which means that we have to
    upgrade again soon. (and haven't i read that new WDSC is not based on
    eclipse anymore but is a piece of Rational Software???)

    OK, I understand that Software is improving and that it is very difficult to
    support all previous versions for many years. But:
    What about the upgrade issues for Developers? At the moment we have
    installed WDSC on 2 desktops only but 5 developers are awaiting to receive
    their version... but I'm affraid to install them because it takes LOTS OF
    TIME to install upgrades! For every upgrade I have to:
    1) remove the previous version
    2) clean up the PC
    3) install the new version
    4) Convert the projects
    5) Check and convert CVS-info
    6) Test these new project versions in TestEnvironment
    7) Rollout these projects in new WebSphere

    I wonder if the rest of the world, which is obviously using WDSC, has same
    installation issues too?

    How do you do it guy's?
    What about installing in Citrix Environment?

    thanks for your info.



  2. Re: WDSC update development software: Who?

    Patrick Goovaerts wrote:
    > upgrade again soon. (and haven't i read that new WDSC is not based on
    > eclipse anymore but is a piece of Rational Software???)

    RAD6 is in Eclipse 3.0. Earlier versions were in earlier versions of
    Eclipse.

    > I wonder if the rest of the world, which is obviously using WDSC, has same
    > installation issues too?

    Is that AS400-specific? Maybe some of the problems are too although
    major WSAD/RAD upgrades do take a lot of time. All complex IDEs like
    these will cause pain doing major release updates and when you're
    dealing with J2EE you're also usually fighting concurrent updates there
    as well.

    > How do you do it guy's?

    We're pretty disorganized so we just suffer through it but we stick with
    each version we use as long as possible.

    > What about installing in Citrix Environment?

    I'm not sure what that would get you but I'm also not sure it's legal.
    Check your license.

  3. Re: WDSC update development software: Who?

    Patrick Goovaerts wrote:
    > Hi,
    >
    > Since a couple of years now we are using WDSC or it's former versions. From
    > time to time we had to upgrade this developer software because of the
    > upgrade of our Websphere Application Server. Last year we decided not to
    > upgrade and kept on using Websphere version 4.0.7 Untill we got that fine
    > message from IBM that WSAS 4.x was not supported anymore...
    >
    > We had to opgrade the WebServer to V5.x and because of that we also needed
    > to upgrade our WDSC because our version did not support WSAS V5. And yes, I
    > know, Version 6 is already on the market... which means that we have to
    > upgrade again soon. (and haven't i read that new WDSC is not based on
    > eclipse anymore but is a piece of Rational Software???)

    WDSc has 2 versions (Standard and Advanced). WDSC is based on Rational
    Web Developer and Rational Application Developer respectively.


    > OK, I understand that Software is improving and that it is very difficult to
    > support all previous versions for many years. But:
    > What about the upgrade issues for Developers? At the moment we have
    > installed WDSC on 2 desktops only but 5 developers are awaiting to receive
    > their version... but I'm affraid to install them because it takes LOTS OF
    > TIME to install upgrades! For every upgrade I have to:
    > 1) remove the previous version
    > 2) clean up the PC
    > 3) install the new version
    > 4) Convert the projects
    > 5) Check and convert CVS-info
    > 6) Test these new project versions in TestEnvironment
    > 7) Rollout these projects in new WebSphere
    >
    > I wonder if the rest of the world, which is obviously using WDSC, has same
    > installation issues too?


    Many customers will setup a test suite before rolling out a new version
    to developers. From a tools perspective the it shouldn't break your
    existing application so they make sure the code builds, runs as
    expected. In your case you will be migrating from Websphere 4 to
    Websphere 5 or 6. The migration should not be that painfull depending
    your existing code. IBM typically supports n-2 releases of Websphere.

    > How do you do it guy's?
    > What about installing in Citrix Environment?

    WDSc is not supported in a Citrix Environment

    >
    > thanks for your info.
    >
    >


+ Reply to Thread