problem creating webservice client usnig WSAD5.1 - Websphere

This is a discussion on problem creating webservice client usnig WSAD5.1 - Websphere ; Hello, I am trying to create a web service client project in IBM WSAD 5.1 from a wsdl file on web service runtime: IBM WebSphere 5.0.2 server: WebSphere v5.0 Test Environment The service element in wsdl is as follows. ort ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: problem creating webservice client usnig WSAD5.1

  1. problem creating webservice client usnig WSAD5.1

    Hello,
    I am trying to create a web service client project in IBM WSAD 5.1 from a wsdl file on
    web service runtime: IBM WebSphere 5.0.2
    server: WebSphere v5.0 Test Environment

    The service element in wsdl is as follows.



    ort binding="intf:CadTeamSoapBinding" name="CadTeam">



    ort>



    As you could notice, the web service is running on https.

    Now, using IBM WSAD 5.1,
    web service runtime: IBM WebSphere 5.0.2,
    server: WebSphere v5.0 Test Environment,

    when I try to create a web service client with this wsdl file,
    I get an error message saying,

    Error: Emitter failure. Invalid endpoint address in port CadTeam in service CadTeamServiceLocator: https://k1wdw15/SampleEJBWebService/services/CadTeam


    If I change https to be http then the client is generated fine, but my web service is actually runnin on https.

    any help please..




  2. Re: problem creating webservice client usnig WSAD5.1

    Strange problem. I don't know if this will work, but try changing it to
    http but set the port to :443.



    omarshareefshaik@yahoo.com wrote:

    > Hello,
    > I am trying to create a web service client project in IBM WSAD 5.1 from a wsdl file on
    > web service runtime: IBM WebSphere 5.0.2
    > server: WebSphere v5.0 Test Environment
    >
    > The service element in wsdl is as follows.
    >
    >
    >
    > ort binding="intf:CadTeamSoapBinding" name="CadTeam">
    >
    >
    >
    >
    ort>
    >
    >

    >
    > As you could notice, the web service is running on https.
    >
    > Now, using IBM WSAD 5.1,
    > web service runtime: IBM WebSphere 5.0.2,
    > server: WebSphere v5.0 Test Environment,
    >
    > when I try to create a web service client with this wsdl file,
    > I get an error message saying,
    >
    > Error: Emitter failure. Invalid endpoint address in port CadTeam in service CadTeamServiceLocator: https://k1wdw15/SampleEJBWebService/services/CadTeam
    >
    >
    > If I change https to be http then the client is generated fine, but my web service is actually runnin on https.
    >
    > any help please..
    >
    >
    >



+ Reply to Thread