Hi,

I have just recently upgrade WSAD 5.0 to WSAD 5.1.1 but there are some
problem when i try to use the WTE 5.1 to run my application which is
running fine in WTE 5.0 in WSAD 5.0.
It give a error complaining about
[Servlet Error]-[sun/jdbc/odbc/JdbcOdbcDriver]:
java.lang.NoClassDefFoundError: sun/jdbc/odbc/JdbcOdbcDriver

I have try to look for the rt.jar that containing this class in the
E:\IBM\WSAD511\runtimes\base_v51\java\jre folder but it is not in
there.
But the file exist in the WTE 5.0 folder. I would appreciate if anyone
can let me know where do the WTE pick up the rt.jar files ?
How do i be able to solve these problems ?

Your help is much appreciated.
Below is the console display

************ Start Display Current Environment ************
WebSphere Platform 5.1 [BASE 5.1.0 b0344.02] running with process
name localhost\localhost\server1 and process id 1024
Host Operating System is Windows 2000, version 5.0
Java version = J2RE 1.4.1 IBM Windows 32 build cn1411-20031011 (JIT
enabled: jitc), Java Compiler = jitc, Java VM name = Classic VM
was.install.root = E:\IBM\WSAD511\runtimes\base_v51
user.install.root = E:\IBM\WSAD511\runtimes\base_v51
Java Home = E:\IBM\WSAD511\runtimes\base_v51\java\jre
ws.ext.dirs = E:\IBM\WSAD511\runtimes\base_v51/java/lib;E:\IBM\WSAD511\runtimes\base_v51/classes;E:\IBM\WSAD511\runtimes\base_v51/classes;E:\IBM\WSAD511\runtimes\base_v51/lib;E:\IBM\WSAD511\runtimes\base_v51/lib/ext;E:\IBM\WSAD511\runtimes\base_v51/web/help;E:\IBM\WSAD511\runtimes\base_v51/deploytool/itp/plugins/com.ibm.etools.ejbdeploy/runtime;D:/Program
Files/SQLLIB/java/db2java.zip;E:/IBM/WSAD511/wstools/eclipse/plugins/com.ibm.etools.webservice_5.1.1/runtime/worf.jar
Classpath = E:\IBM\WSAD511\runtimes\base_v51/properties;E:\IBM\WSAD511\runtimes\base_v51/properties;E:\IBM\WSAD511\runtimes\base_v51/lib/bootstrap.jar;E:\IBM\WSAD511\runtimes\base_v51/lib/j2ee.jar;E:\IBM\WSAD511\runtimes\base_v51/lib/lmproxy.jar;E:\IBM\WSAD511\runtimes\base_v51/lib/urlprotocols.jar;E:/IBM/WSAD511/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.1.1/runtime/wteServer
..jar;E:/IBM/WSAD511/wstools/eclipse/plugins/com.ibm.etools.websphere.tools.common_5.1.1/runtime/wasToolsCommon.jar
Java Library path = E:\IBM\WSAD511\runtimes\base_v51/bin;E:\IBM\WSAD511\runtimes\base_v51/java/bin;E:\IBM\WSAD511\runtimes\base_v51/java/jre/bin;E:\IBM\WSAD511\eclipse\jre\bin;.;E:\IBM\WSAD51 1\eclipse\jre\bin;C:\WINNT\system32;C:\WINNT;C:\WI NNT\system32\WBEM;D:\IBM\WebSphere
MQ\Java\lib;C:\PROGRA~1\ULTRAE~1;D:\IBM\WebSphere
MQ\bin;D:\IBM\WebSphere
MQ\WEMPS\bin;D:\dev_progs\cvsnt;d:\jdk1.3.1\bin;D: \dev_progs\apache-ant-1.5.2\bin;D:\Program
Files\SQLLIB\BIN;D:\Program Files\SQLLIB\FUNCTION;D:\Program
Files\SQLLIB\SAMPLES\REPL;D:\Program
Files\SQLLIB\HELP;D:\PROGRA~1\IBM\IMNNQ;e:\IBM\edg e\lb\servers\lib;
************* End Display Current Environment *************

Regards
Lim