"This portlet is unavailable" error - Websphere

This is a discussion on "This portlet is unavailable" error - Websphere ; I am trying to deploy a existing portlet on portal server V5.1. When I try to access the portlet thru the browser, it gives an error "This portlet is currently unavailable". The sysout.log file has the following error: 00000048 WebExtensionP ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: "This portlet is unavailable" error

  1. "This portlet is unavailable" error

    I am trying to deploy a existing portlet on portal server V5.1. When I try to access the portlet thru the browser, it gives an error "This portlet is currently unavailable". The sysout.log file has the following error:

    00000048 WebExtensionP W Servlet JS Resource Servlet is currently unavailable: SRVE0201E: Servlet [com.ibm.faces.webapp.JSResourceServlet]: not a servlet class
    00000048 WebExtensionP E SRVE0026E: [Servlet Error]-[javax.servlet.UnavailableException: SRVE0201E: Servlet [com.ibm.faces.webapp.JSResourceServlet]: not a servlet class

    Any ideas what could be wrong and how to resolve this error?

    Thanks.

  2. Re: "This portlet is unavailable" error

    attached system out logs might not be the actual error message why portlet is unavailable.. check the log latest wps*.log file which might contain the actual error information... 2 cents...

  3. Re: "This portlet is unavailable" error

    Quote Originally Posted by unix View Post
    I am trying to deploy a existing portlet on portal server V5.1. When I try to access the portlet thru the browser, it gives an error "This portlet is currently unavailable". The sysout.log file has the following error:

    00000048 WebExtensionP W Servlet JS Resource Servlet is currently unavailable: SRVE0201E: Servlet [com.ibm.faces.webapp.JSResourceServlet]: not a servlet class
    00000048 WebExtensionP E SRVE0026E: [Servlet Error]-[javax.servlet.UnavailableException: SRVE0201E: Servlet [com.ibm.faces.webapp.JSResourceServlet]: not a servlet class

    Any ideas what could be wrong and how to resolve this error?

    Thanks.
    I had this an it was driving me crazy. The fix in my case was that I was accidentally shipping the servlet API with my WAR file and hence it was generating a classcastexception (even though it extended HttpServlet). Removing the jar from the war fixed the issue.

    Regards,

    Michael.

+ Reply to Thread