Hello,

My portal application (based on IBM portlet API) is working on WPS 5.1, but there is an error in WPS 6.0.0.1:
[2/12/07 15:26:13:586 PST] 00000039 SystemErr R java.lang.IllegalStateException: Cannot set header in this portlet method: $WSEP,
at com.ibm.wps.pe.pc.legacy.impl.PortletResponseImpl. addHeader(PortletResponseImpl.java:463)
at com.ibm.ws.webcontainer.webapp.WebApp.sendError(We bApp.java:2601)
at com.ibm.ws.jsp.webcontainerext.JSPExtensionServlet Wrapper.handleRequest(JSPExtensionServletWrapper.j ava:175)
at com.ibm.ws.jsp.webcontainerext.JSPExtensionProcess or.handleRequest(JSPExtensionProcessor.java:252)
at com.ibm.ws.webcontainer.webapp.WebAppRequestDispat cher.include(WebAppRequestDispatcher.java:633)
at com.ibm.wps.pe.pc.legacy.impl.PortletContextImpl.i ncludeDirect(PortletContextImpl.java:245)
at com.ibm.wps.pe.pc.legacy.impl.PortletContextImpl.i nclude(PortletContextImpl.java:197)

Does anyone see this problem? Do I need to recompile with new WPS 6.0 library?

Any help will be appreciated,

Thanks in advance,
Chaorong