Websphere Portal 6 - Problem Custom Login (LoginUserAuth) - Websphere

This is a discussion on Websphere Portal 6 - Problem Custom Login (LoginUserAuth) - Websphere ; Sorry, my english is not good enouth,,,, I have a LoginUserAuth made by me,,,, My problem is that i canīt configure it. When i try to login this LoginUSerAuth is not calling,,,,, how can i activate ??? I have made ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Websphere Portal 6 - Problem Custom Login (LoginUserAuth)

  1. Websphere Portal 6 - Problem Custom Login (LoginUserAuth)

    Sorry, my english is not good enouth,,,,

    I have a LoginUserAuth made by me,,,, My problem is that i canīt configure it.

    When i try to login this LoginUSerAuth is not calling,,,,, how can i activate ???

    I have made modifications in portalhome/config/properties/ConfigService.properties
    and i have made modifications in portalhome/config/properties/LoaderService.properties

    (command.path = com.iberdrola.wps.ordenes,com.ibm.wps.engine.comma nds,com.ibm.wps.dynamicui.commands)

    What can i do ???? i need help .....

    thanks in advance

  2. Re: Websphere Portal 6 - Problem Custom Login (LoginUserAuth)


  3. Re: Websphere Portal 6 - Problem Custom Login (LoginUserAuth)

    Hi,
    I have followed the steps for configuring a custom login in WebSphere Portal v6.0.0.1.
    I have written a class com.mycompany.commands.LoginUserAuth that extends com.ibm.wps.engine.commands.LoginUserAuth and where I have overwritten the methods: doPreLogin, doAuthenticate, onAuthenticationError and doPostLogin. Each of these method has a System.out.println(""); instruction and a call to the super method.
    I have putted the jar with my class in \shared\app (I have also tried to put it in \lib\ext).
    I have modified the file \config\properties\LoaderService.properties and set the property
    command.path=com.mycompany.commands,com.ibm.wps.en gine.commands,com.ibm.wps.dynamicui.commands
    and then I have run the command WPSConfig.bat update-properties and restarted the portal.
    The task ends successfully, but when I login into portal, no message was written in SystemOut.log file.

    What have I missed? Any idea?
    Thanks, Roberto.


  4. Re: Websphere Portal 6 - Problem Custom Login (LoginUserAuth)

    You should look in the trace log.

  5. Re: Websphere Portal 6 - Problem Custom Login (LoginUserAuth)

    What do you mean with "You should look in the trace log"?
    Thanks.

+ Reply to Thread