[WPS 6] Authentication failed using LTPA. Exception is WMM-UR :password verification failed - Websphere

This is a discussion on [WPS 6] Authentication failed using LTPA. Exception is WMM-UR :password verification failed - Websphere ; Hi all, I installed a WPS 6.0, enabled security with a Sun DS Ldap already existing with a WPS 5.0 using it, all was working fine, then we have this issue : "L'authentification a échoué lors de l'utilisation de LTPA. ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: [WPS 6] Authentication failed using LTPA. Exception is WMM-UR :password verification failed

  1. [WPS 6] Authentication failed using LTPA. Exception is WMM-UR :password verification failed

    Hi all,

    I installed a WPS 6.0, enabled security with a Sun DS Ldap already existing with a WPS 5.0 using it, all was working fine, then we have this issue :

    "L'authentification a échoué lors de l'utilisation de LTPA. L'exception est WMM-UR: La vérification du mot de passe de l'utilisateur du serveur a échoué.."

    Translated in english is something like that : "Authentication failed using LTPA. Exception is WMM-UR : verification of users's password failed"

    When we want to connect to WAS console.

    The installation :
    * normal install with WASadmin = wpsbind, WPSadmin = wpsadmin, initial cloudscape as DB
    * disable security with [WPS_HOME]/config/WPSconfig.bat disable-security -DWasPassword=wpsbind -DPortalAdminPwd=wpsadmin -Dwmm.DbPassword=ReplaceWithYourDbAdminPwd
    * Edit wpconfig.properties with existing Ldap values
    * Valid config with [WPS_HOME]/config/WPSconfig.bat validate-wmmur-ldap -DWasPassword=wpsbind -DPortalAdminPwd=wpsadmin -DLTPAPassword=wpsbind -DLDAPAdminPwd=wpsadmin
    * Enable security with [WPS_HOME]/config/WPSconfig.bat enable-security-wmmur-ldap -DWasPassword=wpsbind -DPortalAdminPwd=wpsadmin -Dwmm.DbPassword=ReplaceWithYourDbAdminPwd -DLTPAPassword=wpsbind -DLDAPAdminPwd=wpsadmin
    * Launch servers in command line with
    [WAS_HOME]/bin/startServer.bat server1 -username wpsbind -password wpsbind
    [WAS_HOME]/bin/startServer.bat WebSphere_Portal -username wpsadmin -password wpsadmin
    * All is OK, can connect to WAS console with wpsbind/wpsbind, can connect to WPS with wpsadmin and with other users in Ldap.

    But now, we can always start the WAS and WPS, but cannot stop them with the same kind of command line. It says "Fin du programme avec l'erreur : javax.management.JMRuntimeException: ADMN0022E: L'accès est refusé pour l'opération stop sur le MBean Server en raison de justificatifs insuffisants ou vides" (access refused for stop operation on MBean Server, due to insufficient or empty credentials)

    The only thing that as been done is that someone changed the wpsadmin password in the Ldap.
    Knowing that, I updated the wpconfig.properties, and WPS launch's command line.

    But the wpsbind password didn't change, and we still cannot log to WAS console.

    Does someone has an idea of what is wrong ?

    We can start the servers, no error. But when we want to :
    * log to WAS console
    * launch serverStatus.bat -all

    we have an invalid credentials error

    and when we want to go to WPS page : 404 error.


  2. Re: [WPS 6] Authentication failed using LTPA. Exception is WMM-UR :password verification failed

    I disabled security and can now start server (without -username and -password parameters), see serverStatut, connect to WAS console (with wpsbind without password)

    But I can't connect to WPS with wpsadmin... What is the default password, or where is it set ? wpsadmin doesn't work as password...

    I created a user by the WPS subscription system, and I can log with it. But the user was not created in my Ldap, so what logging system is it using ?

    And however, I would like to re activate the security and do it work...

    Anybody has an idea on my first problem ?

+ Reply to Thread