Predeployed portlet is not working - Websphere

This is a discussion on Predeployed portlet is not working - Websphere ; Hi All, I am using RAD6.0 and Portal server 5.1 test environment. I have created JSF portlet and successfully deployed using RAD. When I customized the Portal server settings and deployed the Portlet as a War file. I am getting ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Predeployed portlet is not working

  1. Predeployed portlet is not working

    Hi All,
    I am using RAD6.0 and Portal server 5.1 test environment. I have created JSF portlet and successfully deployed using RAD. When I customized the Portal server settings and deployed the Portlet as a War file. I am getting portlet is unavailable in browser.

    when I checked the log file its showing following error.


    com.ibm.wps.pe.om.definition.impl.WebApplicationDe finitionImpl getServletContext
    EJPPG0003E: ServletContext lookup for /wps/PA_1_0_1385 returned the portal context. It has to be a different one.

    2007.01.11 08:27:42.034 E com.ibm.wps.engine.tags.PortletRenderTag doStartTag
    EJPEJ0066E: The portlet could not be rendered. - StackTrace follows...

    2007.01.11 08:27:42.034 E com.ibm.wps.engine.tags.PortletRenderTag doStartTag
    javax.portlet.UnavailableException: WebApplication is stopped
    at com.ibm.wps.pe.om.definition.impl.WebApplicationDe finitionImpl.getWebAppContext(WebApplicationDefini tionImpl.java:292)
    at com.ibm.wps.pe.om.definition.impl.WebApplicationDe finitionImpl.getServletContext(WebApplicationDefin itionImpl.java:163)
    at com.ibm.wps.pe.om.definition.impl.ServletDefinitio nImpl.getRequestDispatcher(ServletDefinitionImpl.j ava:250)
    at com.ibm.wps.pe.pc.std.invoker.impl.PortletInvokerI mpl.invoke(PortletInvokerImpl.java:186)
    at com.ibm.wps.pe.pc.std.invoker.impl.PortletInvokerI mpl.invoke(PortletInvokerImpl.java:168)
    at com.ibm.wps.pe.pc.std.invoker.impl.PortletInvokerI mpl.render(PortletInvokerImpl.java:97)
    at com.ibm.wps.pe.pc.std.PortletContainerImpl.renderP ortlet(PortletContainerImpl.java:110)
    at com.ibm.wps.pe.pc.PortletContainerImpl.doRenderPor tlet(PortletContainerImpl.java:545)
    at com.ibm.wps.pe.ext.render.AbstractRenderManager.pe rformService(AbstractRenderManager.java:255)
    at com.ibm.wps.pe.pc.PortletContainerImpl.renderPortl et(PortletContainerImpl.java:100)
    at com.ibm.wps.engine.tags.PortletRenderTag.doStartTa g(PortletRenderTag.java:155)
    at org.apache.jsp._Control._jspService(_Control.java: 1926)
    at com.ibm.ws.webcontainer.jsp.runtime.HttpJspBase.se rvice(HttpJspBase.java:89)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java(Compiled Code))
    at com.ibm.ws.webcontainer.jsp.servlet.JspServlet$Jsp ServletWrapper.service(JspServlet.java:385)
    at com.ibm.ws.webcontainer.jsp.servlet.JspServlet.ser viceJspFile(JspServlet.java:739)......


    Anybody can you help me how to solve this problem .. :-(

    Thanks and Regards,
    Roy.

  2. Re: Predeployed portlet is not working



    check this link..

    http://jamiemcilroy.wordpress.com/20...different-one/

    Regards,
    Shyju Thomas

+ Reply to Thread