Upgrading MQ Explorer - Websphere

This is a discussion on Upgrading MQ Explorer - Websphere ; Hi, I have tried to upgrade the MQ Explorer (in MQ v6.0) to Eclipse v3.1.1 by copying all the plugins from the /eclipse/plugins to the /plugins. Unfortunately, when i launched the explorer, the Queue Cluster is missing and i couldn't ...

+ Reply to Thread
Results 1 to 11 of 11

Thread: Upgrading MQ Explorer

  1. Upgrading MQ Explorer

    Hi,

    I have tried to upgrade the MQ Explorer (in MQ v6.0) to Eclipse v3.1.1 by copying all the plugins from the /eclipse/plugins to the /plugins.

    Unfortunately, when i launched the explorer, the Queue Cluster is missing and i couldn't view the properties of the queue manager.

    Does anyone manage to upgrade the explorer successfully or knows how to do it?

    Thanks

  2. Re: Upgrading MQ Explorer

    Hi Ken,

    I have not had much luck trying to use the brute force approach of copying
    the plug-ins to my plug-ins directory, sounds like from your description you
    went this route. I have tried that, but the results have been weird at
    times, one time I had to reinstall Eclipse.

    Have you tried via Software updates off of the Help menu bar? I have had
    more success since I have gone this route. This is from Software Updates ->
    Find and Install, take the search for new features option. This brings up a
    modal, take the Local Site button. This pops up a file selection tree.
    Navigate to where you unraveled the jar. I think I pointed to the eclipse
    directory that was in the unwrapped Eclipse MQ jar. Say OK an install from
    there. Seems like that letting Eclipse install your plug-ins circumvents a
    lot of problems. I don't use the copy any more.

    It would be helpful if IBM had a site to import from. This would be
    cleaner, plus it would be easier to upgrade the Eclipse MQ plug-in. JBOSS
    has a pretty good plug-in update site and Source Forge is hosting more of
    them. Would be great if IBM had one.

    Hope this helps. Maybe some will come up with an Eclipse update site. That
    would be better than what just described.

    Terry



  3. Re: Upgrading MQ Explorer

    a Ken wrote:
    > "from the /eclipse/plugins to the /plugins."
    >
    > sorry abt this, it shld be Websphere MQ/eclipse/plugins to eclipse3.1.1/plugins


    What platform are you running on and do you have Fix Pack 1 installed?

    Thanks,

    Gareth

    --
    Gareth Jones
    WebSphere MQ Development

  4. Re: Upgrading MQ Explorer

    a Ken wrote:
    > I have tried to upgrade the MQ Explorer (in MQ v6.0) to Eclipse v3.1.1


    I don't think anyone has tried that before. Why do you want to upgrade?

    --
    XMS Client Development

  5. Re: Upgrading MQ Explorer

    Not sure this is applicable but I got MQ Explorer working with the current
    Rational SDP. The key was copying the contents of the /links folder, not the
    /plugins because the "real" code is in a file structure under the MQ
    installation directory, not the Eclipse 3.0.1 directory.

    "a Ken" wrote in message
    news:300518733.1138846759205.JavaMail.wassrvr@ltsg was007.sby.ibm.com...
    > "from the /eclipse/plugins to the /plugins."
    >
    > sorry abt this, it shld be Websphere MQ/eclipse/plugins to
    > eclipse3.1.1/plugins




  6. Re: Upgrading MQ Explorer

    Hi,

    I am running eclipse on Win2K server but i am not sure what is the Fix Pack 1 you are talking about.

    Thanks

  7. Re: Upgrading MQ Explorer

    Hi,

    I think its different as Eclipse is plugin based. The usual approach is to copy the plugins into the plugin folder in eclipse. I think in this case, MQ plugin may only be compatible with eclipse3.0.1.

    I am hoping that someone has tried this before successfully.

    cheers

  8. Re: Upgrading MQ Explorer

    Hi,

    There isn't a particular reason. I am thinking of keeping up to date with eclipse, thus tried to migrate to eclipse3.1.1. Unfortunately, its not that straight forward.

    cheers

  9. Re: Upgrading MQ Explorer

    a Ken wrote:
    > Hi,
    >
    > I think its different as Eclipse is plugin based. The usual approach is to copy the plugins into the plugin folder in eclipse. I think in this case, MQ plugin may only be compatible with eclipse3.0.1.
    >
    > I am hoping that someone has tried this before successfully.
    >
    > cheers


    Installing Refresh Pack 6.0.1.0 (what I previously referred to as Fix
    Pack 1) for MQ (download here:
    http://www-1.ibm.com/support/docview...id=swg24010812) should
    allow you to successfully run MQ Explorer in an Eclipse 3.1 based shell.
    However, note this is actually an unsupported environment and any
    problems you may find must first be recreated in the version of Eclipse
    shipped with the product (3.0.1) prior to contacting IBM Customer Support.

    Please also note that the post regarding copying the links directory is
    a correct solution, as is copying the entire plug-ins directory
    itself. Eclipse uses the links directory to include plug-ins elsewhere
    on the file system.

    --
    Gareth Jones
    WebSphere MQ Development

  10. Re: Upgrading MQ Explorer

    a Ken wrote:
    > I am running eclipse on Win2K server but i am not sure what is the Fix Pack 1 you are talking about.


    Gareth means FixPack 1 for WebSphere MQ 6.0, also known as CSD01.

    --
    XMS Client Development

  11. Re: Upgrading MQ Explorer

    Thanks Phil and Gareth for your valuable input.

+ Reply to Thread