What is the minimum C++ compiler version required to compile the get and put samples for Webshere MQ 5.3?

We are currently trying to compile with C++ for OS/390 2.10 which is what came with our install of Z/OS 1.4 and we get compile errors. Do we need C++ for Z/OS 1.4?