I am using WAS 5.1 with MQ 5.3 with all the available fix packs (CSD4, 6, 8, 9 & 10).

I have followed the following steps for MQ using MQ Explorer
1. Created a default configuration
2. Created QueueManager(QMngr) in MQ and enabled the Remote Administration
3. Created a local Queue in QMngr

I have followed the following steps for WAS using Admin Console
1. Created a ConnFactory with the MQ QMngr entries.
2. Created Queue with the MQ QMngr & Queue entries.

I am getting the following error when I start WAS

[7/13/05 3:17:59:858 PDT] 7d71f0ac ManagerAdmin I TRAS0017I: The startup trace state is *=all=disabled.
[7/13/05 3:18:01:040 PDT] 7d71f0ac AdminInitiali A ADMN0015I: AdminService initialized
[7/13/05 3:18:02:843 PDT] 7d71f0ac Configuration A SECJ0215I: Successfully set JAAS login provider configuration class to com.ibm.ws.security.auth.login.Configuration.
[7/13/05 3:18:02:903 PDT] 7d71f0ac SecurityDM I SECJ0231I: The Security component's FFDC Diagnostic Module com.ibm.ws.security.core.SecurityDM registered successfully: true.
[7/13/05 3:18:03:534 PDT] 7d71f0ac SecurityCompo I SECJ0309I: Java 2 Security is disabled.
[7/13/05 3:18:03:534 PDT] 7d71f0ac SecurityCompo I SECJ0212I: WCCM JAAS configuration information successfully pushed to login provider class.
[7/13/05 3:18:03:554 PDT] 7d71f0ac SecurityCompo I SECJ0240I: Security service initialization completed successfully
[7/13/05 3:18:03:564 PDT] 7d71f0ac JMSRegistrati A MSGS0602I: WebSphere Embedded Messaging Client only has been installed
[7/13/05 3:18:06:509 PDT] 7d71f0ac JMSEmbeddedPr A MSGS0050I: Starting the Queue Manager
[7/13/05 3:18:14:041 PDT] 7d71f0ac JMSEmbeddedPr A MSGS0051I: Queue Manager open for business
[7/13/05 3:18:14:051 PDT] 7d71f0ac JMSEmbeddedPr A MSGS0052I: Starting the Broker
[7/13/05 3:18:14:331 PDT] 7d71f0ac BrokerManager E MSGS0255E: Broker Manager unable to attach to Queue Manager - unknown Queue
[7/13/05 3:18:14:352 PDT] 7d71f0ac JMSService E MSGS0001E: Starting the JMS Server failed with exception: com.ibm.mq.MQException: MQJE001: Completion Code 2, Reason 2085
at com.ibm.mq.MQQueueManager.accessQueue(MQQueueManag er.java:1391)
at com.ibm.mq.MQQueueManager.accessQueue(MQQueueManag er.java:1436)
at com.ibm.ws.messaging.BrokerManager.attachToMQ(Brok erManager.java:439)
at com.ibm.ws.messaging.BrokerManager.startBroker(Bro kerManager.java:234)
at com.ibm.ws.messaging.JMSEmbeddedProviderImpl.start (JMSEmbeddedProviderImpl.java:194)
at com.ibm.ws.messaging.JMSService.start(JMSService.j ava:288)
at com.ibm.ws.runtime.component.ContainerImpl.startCo mponents(ContainerImpl.java:536)
at com.ibm.ws.runtime.component.ContainerImpl.start(C ontainerImpl.java:413)
at com.ibm.ws.runtime.component.ServerImpl.start(Serv erImpl.java:183)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:12 8)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:225 )
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:79)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:41)
at java.lang.reflect.Method.invoke(Method.java:386)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.ja va:94)

[7/13/05 3:18:14:362 PDT] 7d71f0ac ContainerImpl E WSVR0501E: Error creating component null [class com.ibm.ws.messaging.JMSService]
com.ibm.ws.exception.RuntimeWarning: MSGS0001E: Starting the JMS Server failed with exception: com.ibm.mq.MQException: MQJE001: Completion Code 2, Reason 2085
at com.ibm.ws.messaging.JMSService.start(JMSService.j ava:295)
at com.ibm.ws.runtime.component.ContainerImpl.startCo mponents(ContainerImpl.java:536)
at com.ibm.ws.runtime.component.ContainerImpl.start(C ontainerImpl.java:413)
at com.ibm.ws.runtime.component.ServerImpl.start(Serv erImpl.java:183)
at com.ibm.ws.runtime.WsServer.start(WsServer.java:12 8)
at com.ibm.ws.runtime.WsServer.main(WsServer.java:225 )
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:79)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:41)
at java.lang.reflect.Method.invoke(Method.java:386)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.ja va:94)


I have seen many posts in this forum for the similar kind of problem and I have ensured that my QMngr & Queues are present & running. There are no spelling mistakes and I have not missed any entry while creating ConnFactory & Queue in WAS.

I have 2 more QMngr in my MQ setup. First one is the default QMngr which is created my MQ while installing MQ. And second QMngr is created by WAS. I also tried using these QMngrs but I got the same error.

I will appreciate any help.

Thanks in advance