Does anyone know if Commerce Studio 5.5 will work with WASD5.1?

thanks,
mark